Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453755 - unregister_netdevice: waiting for vlan10 to become free. Usage count = 1
Summary: unregister_netdevice: waiting for vlan10 to become free. Usage count = 1
Keywords:
Status: CLOSED DUPLICATE of bug 450855
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.2
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Neil Horman
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 12:05 UTC by Juanjo Villaplana
Modified: 2009-06-03 10:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-06-03 10:45:14 UTC


Attachments (Terms of Use)
Network config (deleted)
2008-07-02 12:05 UTC, Juanjo Villaplana
no flags Details

Description Juanjo Villaplana 2008-07-02 12:05:15 UTC
Description of problem:

Can't stop network. When running "service network stop" the following error
appears on syslog and the network doesn't stop:

unregister_netdevice: waiting for vlan10 to become free. Usage count = 1

We are using vlans on top of bonding interfaces.

Version-Release number of selected component (if applicable):

kernel-2.6.18-92.el5 and kernel-2.6.18-92.1.6.el5

Works fine with kernel-2.6.18-53.1.21.el5

How reproducible:

Almost always

Steps to Reproduce:

1. service network stop
  
Actual results:

Network doesn't stop and can't kill "service network stop"

Expected results:

Network interfaces should be stopped

Additional info:

May be a duplicate of Bug 423791 ?

Comment 1 Juanjo Villaplana 2008-07-02 12:05:15 UTC
Created attachment 310782 [details]
Network config

Comment 2 Juanjo Villaplana 2008-07-02 12:35:55 UTC
When disabling IPv6 kernel-2.6.18-92.1.6.el5 also works fine:

    - Add the follwing entries to /etc/modprobe.conf:

      alias net-pf-10 off
      alias ipv6 off

    - chkconfig ip6tables off

Comment 3 Neil Horman 2009-04-07 20:05:36 UTC
can you try the 5.3 kernel (kernel-2.6.9-128.el5)?

I think this might be a dup of bz450855.  That was fixed in -99, correcting an unbalanced reference count which, if leaked, could result in this behavior

Comment 4 Neil Horman 2009-04-16 10:49:03 UTC
ping?  Any results on 5.3 testing?

Comment 5 Juanjo Villaplana 2009-04-20 12:26:20 UTC
I will try to test kernel-2.6.9-128.el5 this week ...

Comment 6 Neil Horman 2009-04-20 13:49:10 UTC
Ok, please report results as soon as you have them.  Thank you!

Comment 7 Neil Horman 2009-05-18 14:25:40 UTC
ping, any update?

Comment 8 Juanjo Villaplana 2009-06-03 08:35:42 UTC
Tested with kernel 2.6.18-128.1.6.el5:

1. Removed net-pf-10 and ipv6 entries from /etc/modprobe.conf
2. Started ip6tables
3. Issued several 'service network restart' and all worked fine
4. Restarted the server.
5. Issued several 'service network restart' and all worked fine

The issue seems to be solved. Thanks!

Comment 9 Neil Horman 2009-06-03 10:45:14 UTC
k, thank you!

*** This bug has been marked as a duplicate of bug 450855 ***


Note You need to log in before you can comment on or make changes to this bug.