Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453753 - LVM2 allows final MDA to be removed from a VG
Summary: LVM2 allows final MDA to be removed from a VG
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2
Version: 5.2
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Milan Broz
QA Contact: Cluster QE
URL:
Whiteboard:
: 461306 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 11:30 UTC by Bryn M. Reeves
Modified: 2018-10-20 02:36 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:46:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0179 normal SHIPPED_LIVE lvm2 bug-fix and enhancement update 2009-01-20 16:05:45 UTC

Description Bryn M. Reeves 2008-07-02 11:30:23 UTC
+++ This bug was initially created as a clone of Bug #247448 +++

Description of problem:
LVM2 permits PVs to be created with 0 or more metadata areas. Creating volume
groups with less MDAs than PVs improves tool performance for VGs with large
numbers of PVs.

Currently the tools permit the last MDA to be removed from a VG with no warning,
causing the VG to suddenly "disappear". 

Version-Release number of selected component (if applicable):
lvm2-2.02.21-5.el4, lvm2-2.02.24-1.fc7, lvm2 CVS 20070707.

How reproducible:
100%

Steps to Reproduce:
1. Create a volume group with #MDAS < #PVs:
pvcreate --metadatacopies=1 /dev/loop0
pvcreate --metadatacopies=0 /dev/loop1
vgcreate t0 /dev/loop0 /dev/loop1

2. Attempt to remove the PV that contains the MDA
vgreduce t0 /dev/loop0
 
Actual results:
# vgreduce t0 /dev/loop0
  Removed "/dev/loop0" from volume group "t0"
# vgs
  No volume groups found



Expected results:
# vgreduce t0 /dev/loop0
  Can't remove final metadata area on physical volume "/dev/loop0" from volume
group "t0"


Additional info:

Comment 3 RHEL Product and Program Management 2008-07-02 11:49:53 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Milan Broz 2008-07-03 09:36:12 UTC
Commited to CVS in version lvm2-2.02.39-1.el5.

Comment 5 Milan Broz 2008-09-05 19:05:51 UTC
*** Bug 461306 has been marked as a duplicate of this bug. ***

Comment 10 Corey Marthaler 2008-09-10 19:10:17 UTC
Fix verified in lvm2-2.02.39-2.el5. 

"Cannot remove final metadata area on "/dev/etherd/e1.1p3" from "mirror_sanity""

Comment 13 errata-xmlrpc 2009-01-20 21:46:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0179.html


Note You need to log in before you can comment on or make changes to this bug.