Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453752 - ssh hangs after login
Summary: ssh hangs after login
Keywords:
Status: CLOSED DUPLICATE of bug 242870
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: 9
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Jan F. Chadima
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 11:20 UTC by krishnakumar ravikumar
Modified: 2009-05-04 12:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-04 12:04:39 UTC


Attachments (Terms of Use)

Description krishnakumar ravikumar 2008-07-02 11:20:26 UTC
Description of problem:
After loggin on to a server through ssh the session hangs abruptly.
I disabled selinux and firewall, but still the problem persists.
I use fedora 9 on IBM T60 notebook.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Tomas Mraz 2008-07-02 12:16:30 UTC
Can you reproduce it with one particular server or just any server? What is the
server openssh version? Can you try ssh -vvv <server> and see if there are any
suspicious messages in the debug output? Also you could try to install
openssh-debuginfo package and see where the ssh process is stuck by attaching a
gdb to the hanging ssh client process.


Comment 3 krishnakumar ravikumar 2008-07-03 16:05:13 UTC
I use 
OpenSSH_5.0p1, OpenSSL 0.9.8g 19 Oct 2007
in my fedora 9 machine and the server has 
OpenSSH_4.7p1, OpenSSL 0.9.8b 04 May 2006

I tried ssh -vvv, but there is nothing spurious in the output. The session just
hangs in the middle.

I will try the debug package


Comment 4 krishnakumar ravikumar 2008-07-07 22:56:08 UTC
The problem comes only when I use wireless.
If I use Ethernet port...then the ssh works fine



Comment 5 Tomas Mraz 2008-10-17 08:13:12 UTC
This can be caused by buggy router dropping packets from the openssh protocol. I do not think this is caused by openssh itself.

Comment 6 Fedora Admin XMLRPC Client 2009-03-10 10:14:26 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 7 Tomas Mraz 2009-05-04 12:04:39 UTC

*** This bug has been marked as a duplicate of bug 242870 ***


Note You need to log in before you can comment on or make changes to this bug.