Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453749 - shared-mime-info postinstall script is umask sensitive.
Summary: shared-mime-info postinstall script is umask sensitive.
Keywords:
Status: CLOSED DUPLICATE of bug 83006
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: shared-mime-info
Version: 5.2
Hardware: i386
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Bastien Nocera
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 10:54 UTC by Jarno Huuskonen
Modified: 2008-07-02 11:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-02 11:03:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jarno Huuskonen 2008-07-02 10:54:23 UTC
Description of problem:
Postinstall script for shared-mime-info-0.19-5.el5 is umask dependent.
If umask is 077, then /usr/share/mime/{aliases,globs,magic} etc.
get 0600 permissions --> problems when regular users (for example evince
complains about unhandled mime types).

Version-Release number of selected component (if applicable):
shared-mime-info-0.19-5.el5

How reproducible:

Steps to Reproduce:
1. set root's umask to 077
2. run update-mime-database /usr/share/mime
3. (or update/install shared-mime-info).
  
Actual results:
# ls -la /usr/share/mime/{aliases,globs,magic}
-rw------- 1 root root  2419 Jul  2 13:50 /usr/share/mime/aliases
-rw------- 1 root root 13661 Jul  2 13:50 /usr/share/mime/globs
-rw------- 1 root root 11849 Jul  2 13:50 /usr/share/mime/magic

Expected results:
-rw-r--r-- 1 root root  2419 Jul  2 13:50 /usr/share/mime/aliases
-rw-r--r-- 1 root root 13661 Jul  2 13:50 /usr/share/mime/globs
-rw-r--r-- 1 root root 11849 Jul  2 13:50 /usr/share/mime/magic

Additional info:
shared-mime-info postinstall script (or update-mime-database program) should set
umask to 022 before updating files.

Comment 1 Bastien Nocera 2008-07-02 11:03:08 UTC
See also bug 195414

*** This bug has been marked as a duplicate of 83006 ***


Note You need to log in before you can comment on or make changes to this bug.