Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453742 - DRI acceleration is slow
Summary: DRI acceleration is slow
Keywords:
Status: CLOSED DUPLICATE of bug 444328
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 09:51 UTC by Zdenek Kabelac
Modified: 2018-04-11 12:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-21 14:24:46 UTC


Attachments (Terms of Use)
Log from Xorg server without any xorg.conf (deleted)
2008-07-08 08:49 UTC, Zdenek Kabelac
no flags Details

Description Zdenek Kabelac 2008-07-02 09:51:43 UTC
Description of problem:

I've noticed that acceleration of OpenGL apps is getting very slow.
I've checked couple settings & different kernels and I'm unable to pass 560fps
in glxgears which is of course no benchmark but gives at least some numbers.

debug vanilla kernel 2.6.26-rc -   ~500fps
(current fedora rawhide kernel is even slower is it uses even more debug config
options)
fast vanilla kernel (no debugs)  2.6.26-rc -   ~560fps

vesa driver and default glxgears window size   720fps 
(though vesa gets noticeable slower when the window is resized)


I know that 1.4.1 is able to achieve 1080fps on the same hw and F8 gives still
pretty nice 800fps without any tunning.



Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.2.1-24.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.902-3.20080612.fc9.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2008-07-07 10:10:00 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Zdenek Kabelac 2008-07-08 08:49:09 UTC
Created attachment 311241 [details]
Log from Xorg server without any xorg.conf

This log is from the Xorg server running without any configuration file - and
as this also give the same 'speed' result I guess it's enough.

I'd like to note, that even plain Xorg :0 -ac without any other fancy tool -
just glxgears - gives the same speed.

Comment 3 Zdenek Kabelac 2008-07-08 11:37:42 UTC
Ok - I've additional information about this problem:

It looks like glxgears are 'slow' so they will not make a significant load on
CPU - thus my ondemand CPU governor actually doesn't increase CPU speed. This
explains why I've seen several times higher numbers with glxgears - happend with
CPU load caused by ff3...

So with 'perfomance' cpu governor - and my debug kernel I get ~630FPS - (this
shows, that there might be some problem with data exchange between CPU & GPU and
both are waitting for each other.  This gives estimated 760fps with non-debug
fullspeed kernel - which is still slower than F8.


Those >1000fps were achieved with slightly faster C2D 2.4GHz - mine is just
2.2GHz - and with current Xorg head that machine achieves just 900fps.

So there is certainly a MESA problem most probably as well.



Comment 4 Zdenek Kabelac 2008-07-08 12:32:26 UTC
For me to be able to still use ondemand governor while having better gears
speed, I have done this:

echo 30>/sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold

This seems to push CPU into faster Cx state under smaller load and makes
glxgears to archive maximal speed.


Comment 5 Matěj Cepl 2008-07-08 13:52:20 UTC
So, OK, let's blame mesa.

Comment 6 Bug Zapper 2008-11-26 02:30:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Vedran Miletić 2009-09-21 14:24:46 UTC

*** This bug has been marked as a duplicate of bug 444328 ***


Note You need to log in before you can comment on or make changes to this bug.