Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453723 - orphan packages in comps.xml
Summary: orphan packages in comps.xml
Keywords:
Status: CLOSED DUPLICATE of bug 363101
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: comps
Version: 5.4
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Dennis Gregorovic
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 08:14 UTC by Simon Xu
Modified: 2009-02-05 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-05 16:55:54 UTC


Attachments (Terms of Use)

Description Simon Xu 2008-07-02 08:14:27 UTC
Description of problem:

The following packages are listed in 5.2 comps.xml but cannot be
found in 5.2 i386 release Base repo:

ckermit
clustermon
compat-gcc-295
compat-gcc-296
compat-gcc-32
compat-gcc-32-g77
compat-gcc-c++-32
compat-libgcc-295
compat-libstdc++-295
compat-libstdc++-32
conga-devel
ddd
elilo
elsa
fonts-ISO8859-9-75dpi
gfs
gnopernicus
httpd-suexec
inkscape
iprutils
java-1.4.2-gcj-compat-plugin
kdepim-devel
kernel-kdump
kmod-gfs-kdump
kmod-gnbd-kdump
lha
libica
libipathverbs
libpng10-devel
libungif-devel
longrun
mcelog
netconfig
notify-daemon
open
openoffice.org-langpack-ur_IN
openssl-ibmca
perl-Cyrus
ppc64-utils
prctl
pup
rhel-instnum
rhn-check
rhn-setup
rhn-setup-gnome
ricci-modcluster
s390utils
salinfo
strace64
sysfsutils-devel
system-config-printer-gui
totem-mozplugins
valgrind-callgrind
yaboot
yum-rhn-plugin

The following packages are listed in 5.2 comps.xml but cannot be
found in 5.2 x86_64 release Base repo:

apmd
ckermit
clustermon
compat-gcc-295
compat-gcc-296
compat-gcc-32
compat-gcc-32-g77
compat-gcc-c++-32
compat-libgcc-295
compat-libstdc++-295
compat-libstdc++-32
conga-devel
ddd
elilo
elsa
fonts-ISO8859-9-75dpi
gfs
gnopernicus
gnu-efi
gpart
httpd-suexec
ibmasm
inkscape
iprutils
java-1.4.2-gcj-compat-plugin
kernel-kdump
kmod-gfs-kdump
kmod-gnbd-kdump
lha
libica
libpng10-devel
libungif-devel
longrun
netconfig
notify-daemon
open
openoffice.org-langpack-ur_IN
openssl-ibmca
perl-Cyrus
ppc64-utils
prctl
pup
rhel-instnum
rhn-check
rhn-setup
rhn-setup-gnome
ricci-modcluster
s390utils
salinfo
strace64
sysfsutils-devel
system-config-printer-gui
totem-mozplugins
valgrind-callgrind
yaboot
yum-rhn-plugin

In addition, an `eclipse' group is listed in category `apps', a `workstation'
group is listed in category `base-system', but these two groups are not defined
in comps.xml.

And, there's a `notify-daemon' package in the `gnome-desktop' group, but there
isn't any `notify-daemon' package in RHEL 5.1 or 5.2 release, instead, there's a
`notification-daemon' package.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dennis Gregorovic 2008-09-05 17:14:30 UTC
Are you getting the comps.xml data from RHN or the ISOs?

Comment 2 Simon Xu 2008-09-07 01:20:01 UTC
I got the comps.xml from CentOS 5.2.  People say that the comps.xml of CentOS is identical of that of the RHEL.  So I reported a bug here.

Comment 3 Dennis Gregorovic 2009-02-03 19:37:32 UTC
If you post the comps.xml that you are using I can compare it against RHEL's comps.xml, but my guess is that they're different.

Comment 4 Simon Xu 2009-02-04 00:24:18 UTC
See Comment #2, you can get the comps.xml from CentOS 5.2.  People in centos irc channel (irc.freenode.org) told me that the comps.xml of CentOS is identical of that of the RHEL.

Comment 5 Dennis Gregorovic 2009-02-05 16:55:54 UTC
After some investigation, the cause of these orphan packages appears to be the same as bug #363101

*** This bug has been marked as a duplicate of bug 363101 ***


Note You need to log in before you can comment on or make changes to this bug.