Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453722 - (open)motif apprications dump core in non-UTF8 environment.
Summary: (open)motif apprications dump core in non-UTF8 environment.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openmotif
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 08:09 UTC by Akira YOSHIYAMA
Modified: 2009-06-20 04:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 22:17:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0247 normal SHIPPED_LIVE openmotif bug fix and enhancement update 2009-01-20 16:06:50 UTC

Description Akira YOSHIYAMA 2008-07-02 08:09:19 UTC
Description of problem:
In non-UTF8 environment, (open)motif apprications dump core when 
entry in menu bar was clicked with button2 (middle button of mouse).

Version-Release number of selected component (if applicable):
2.3.0-3.el5

How reproducible:
frequent

Steps to Reproduce:
1.rebuild openmotif demos
2.set any non-UTF-8 locale to LC_ALL
3.run some demo and click any menu bar entry with button2
  
Actual results:
program aborted.

Expected results:
no problem.

Additional info:
Valgrind found a bug in _XmLabelConvert() on openmotif-2.3.0/lib/Xm/Label.c.
Array "targs[]" has 5 room, but targs[5] and targs[6] were set 
because of UTF8_SUPPORTED macro.

Comment 1 Thomas Woerner 2008-07-02 13:14:51 UTC
This has been fixed upstream:
http://openmotif.cvs.sourceforge.net/openmotif/openmotif/lib/Xm/Label.c?r1=1.11&r2=1.12

Comment 2 RHEL Product and Program Management 2008-07-02 13:53:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Akira YOSHIYAMA 2008-07-04 06:51:05 UTC
Thank you for your reply. I have a question.
The upstream fix makes "targs[]" size to 6, but _XmLabelConvert() looks
being able to set targs[6]. Is it ok?

Comment 4 Thomas Woerner 2008-07-04 10:40:43 UTC
I also thought about that and contacted upstream.

Comment 6 Thomas Woerner 2008-07-09 15:20:18 UTC
Upstream agrees. The size of targs is now 7:

http://openmotif.cvs.sourceforge.net/openmotif/openmotif/lib/Xm/Label.c?r1=1.13.2.3&r2=1.13.2.4

Comment 7 Akira YOSHIYAMA 2008-07-10 12:23:34 UTC
Oh! ... ok, thank you for your support.
Please apply it for the next rpm release.

Comment 15 errata-xmlrpc 2009-01-20 22:17:09 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0247.html


Note You need to log in before you can comment on or make changes to this bug.