Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453693 - Fedora Core 9: xorg savage driver freezes display with quad-screen
Summary: Fedora Core 9: xorg savage driver freezes display with quad-screen
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-02 02:08 UTC by Marcus O. White
Modified: 2018-04-11 17:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-14 17:45:04 UTC


Attachments (Terms of Use)
xorg.conf (deleted)
2008-07-02 12:58 UTC, Marcus O. White
no flags Details
Xorg.0.log (deleted)
2008-07-02 12:59 UTC, Marcus O. White
no flags Details
Error log without an /etc/X11/xorg.conf file present (deleted)
2008-07-02 19:18 UTC, Marcus O. White
no flags Details

Description Marcus O. White 2008-07-02 02:08:50 UTC
Description of problem:

I recently updated FC8 to FC9 and in so doing the new Savage Driver version
2.2.0-2 freezes the display on initializing the video card (int10), a quad vga
Colorgraphic Predator LT 4 PCI. Thru trial and error I was to get a simple test
to work partially. That is 3 of the 4 screens will initialize and display the
test session (ie X -config /xorg.conf.new) by using the option "NoInt10" in each
device section.

This same hardware setup previously worked under FC6-8 and no longer works on
FC9. The base system is a Dell Precision 340 with 512Mb RAM and an Intel 4
2.66Ghz CPU. The system is configured to operate under quad displays with
Xinerama set to "true". Once the display freezes, a reboot (ctrl-alt-del) to
restore system.

The display also freezes if attempting to create a basic xorg.conf with "X
-configure".

If I set the config to use only one display the system works normally with using
the default setting for Int10. Does the driver no longer support multiple displays?

Version-Release number of selected component (if applicable):

Fedora Core 9/xorg-x11-drv-savage-2.2.0-2.fc9

How reproducible:

Start system in graphic mode

Steps to Reproduce:
1. Start system
2. Allow to boot
3.
  
Actual results:

The display freezes on startup in gui mode

Expected results:

Normal gui display
Additional info:

Comment 1 Marcus O. White 2008-07-02 12:58:13 UTC
Created attachment 310785 [details]
xorg.conf

Existing xorg configuration file. This configuration worked prior to upgrading
to FC9.

Comment 2 Marcus O. White 2008-07-02 12:59:02 UTC
Created attachment 310786 [details]
Xorg.0.log

Xorg log file.

Comment 3 Marcus O. White 2008-07-02 13:00:46 UTC
The display freezes on a black text screen.

Comment 4 Matěj Cepl 2008-07-02 16:51:00 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please try to run without any /etc/X11/xorg.conf whatsoever and let X11
autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log,
please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 5 Marcus O. White 2008-07-02 19:18:47 UTC
Created attachment 310843 [details]
Error log without an /etc/X11/xorg.conf file present

A single video display vs a quad-display was successfully displayed.

Comment 6 Matěj Cepl 2008-07-02 21:48:37 UTC
(In reply to comment #5)
> A single video display vs a quad-display was successfully displayed.

Yes, I understand that, but I just wanted to eliminate problems in the
configuration.

Reassigning to developers.

Comment 7 Marcus O. White 2008-07-03 00:38:40 UTC
Understood... I was just a statement to clarify the results of the error log...

Comment 8 Marcus O. White 2008-07-08 17:17:10 UTC
I've downgraded xorg to the FC8 version 1.3.0 and the savage driver works again
with the quad vga Colorgraphic Predator LT 4 PCI video adapter. Should a fix
become available I will upgrade xorg to FC9 version.

I used the method described here: 

http://www.fedoraforum.org/forum/showthread.php?p=1003106#post1003106

and here:

http://www.fedoraforum.org/forum/showthread.php?t=188645&page=1&pp=15



Comment 9 Bug Zapper 2009-06-10 01:52:39 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Bug Zapper 2009-07-14 17:45:04 UTC
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.