Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453670 - rhel4u7 paravirt guests are uninstallable?
Summary: rhel4u7 paravirt guests are uninstallable?
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xen
Version: 4.7
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 19:53 UTC by Gurhan Ozen
Modified: 2013-11-04 01:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-01 20:24:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gurhan Ozen 2008-07-01 19:53:07 UTC
Description of problem:
Not sure if this is related to the fix that went in for #447315 or not, but on a
rhel5.2 dom0 , paravirt guest installations for RHEL4-U7-re20080625.0 tree fail
for nothing having a harddisk:


                     +------------+ Warning +------------+
                     |                                   |
                     | No hard drives have been found.   |
                     | You probably need to manually     |
                     | choose device drivers for the     |
                     | installation to succeed.  Would   |
                     | you like to select drivers now?   |
                     |                                   |
                     |     +-----+           +----+      |
                     |     | Yes |           | No |      |
                     |     +-----+           +----+      |
                     |                                   |
                     |                                   |
                     +-----------------------------------+


If Yes is selected the following screen is given:

                                                                                
                                                                                
           +----------------------+ Devices +-----------------------+           
           |                                                        |           
           | The following devices have been found on your system.  |           
           |                                                        |           
           |          Xen network frontend device (xennet)          |           
           |                                                        |           
           |        +------+                 +------------+         |           
           |        | Done |                 | Add Device |         |           
           |        +------+                 +------------+         |           
           |                                                        |           
           |                                                        |           
           +--------------------------------------------------------+           
                                                                                

When moved on, anaconda also prints outs the following messages:

Running anaconda, the Red Hat Enterprise Linux system installer - please wait...
mmap /dev/mem: Bad address
Probing for video card:   Unable to probe
mmap /dev/mem: Bad address
Probing for monitor type:   Unknown monitor

Ultimately this fails in partitioning harddrive step:

                 +------------+ No Drives Found +-------------+
                 |                                            |
                 | An error has occurred - no valid devices   |
                 | were found on which to create new file     |
                 | systems. Please check your hardware for    |
                 | the cause of this problem.                 |
                 |                                            |
                 |                  +----+                    |
                 |                  | OK |                    |
                 |                  +----+                    |
                 |                                            |
                 |                                            |
                 +--------------------------------------------+


This only happens with paravirt guests, wasn't able to reproduce it with hvm
guests. Happens for both i386 and x86_64 arches , amd/intel cpus,
file/lvm/block-based backends. Also was able to reproduce with both vanilla 5.2
xen and z-stream 5.2 xen (3.0.3-64.el5_2.1) rpms. 

Version-Release number of selected component (if applicable):
# uname -a
Linux amd-tyan-09.lab.bos.redhat.com 2.6.18-92.el5xen #1 SMP Tue Apr 29 13:45:57
EDT 2008 i686 athlon i386 GNU/Linux
# rpm -qa | grep ^xen 
xen-libs-3.0.3-64.el5_2.1
xen-3.0.3-64.el5_2.1


How reproducible:
Very.

Steps to Reproduce:
1. virt-install --name rhel4u7_pv_i386 --location
nfs:bigpapi.bos.redhat.com:/vol/engineering/redhat/rel-eng/RHEL4-U7-re20080625.0/i386/i386-AS
--file /var/lib/xen/images/rhel4u7_pv_i386.img --paravirt --nographics -s 10 -r 512 
2.
3.
  
Actual results:
Install fails.

Expected results:
Install should succeed.

Additional info:

Comment 1 Don Dutile 2008-07-01 20:24:30 UTC
The patch posted for 447315 broke pv installs (and boots if updated rpm
added/upgraded in an existing 4.6/pre-4.7 installation).

I was wondering why I hadn't seen a bz about this (broken -xenU) state earlier.

The good news: it's fixed by the post for 452210.

so, marking this bz as a dupe, and making it dependent on 452210.

- Don


*** This bug has been marked as a duplicate of 452210 ***


Note You need to log in before you can comment on or make changes to this bug.