Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453646 - Compile perl with -DPERL_USE_SAFE_PUTENV
Summary: Compile perl with -DPERL_USE_SAFE_PUTENV
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 17:22 UTC by Lubomir Rintel
Modified: 2008-07-06 06:17 UTC (History)
4 users (show)

Fixed In Version: perl-5.10.0-30.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-02 09:49:04 UTC


Attachments (Terms of Use)

Description Lubomir Rintel 2008-07-01 17:22:51 UTC
Description of problem:

Perl by default manages to take care of environment with its custom memory
management routines, to work around leaky putenv() implementations. However,
once a module modifies environment, perl loses track and panics upon deallocation.

For an example of a problem caused by this, see perlbug RT ticket #56500 [1],
where Term::ReadLine::Gnu is the module that modifies environment. It is very
likely that there are other such modules.

[1] http://rt.perl.org/rt3/Ticket/Display.html?id=56500

According to putenv(3) manual it is not necessary for perl to deal with possible
putenv() leaks in Fedora 9, since glibc correctly implements it as of 2.1.2.

According to perl's INSTALL file, the problematic behavior can be disabled with
-DPERL_USE_SAFE_PUTENV switch.

Version-Release number of selected component (if applicable):

perl-5.10.0-32.fc10.i386

Comment 1 Marcela Mašláňová 2008-07-02 09:49:04 UTC
This will hit also rawhide soon.

Comment 2 Lubomir Rintel 2008-07-02 14:37:32 UTC
Thanks a lot. Just for the record -- apart from Term::ReadLine::Gnu this also
reportedly fixed issues with wxPerl and Class::MethodMaker; in case you are
aware of any bugs open that might relate to this.

Comment 3 Fedora Update System 2008-07-06 06:17:28 UTC
perl-5.10.0-30.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.