Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453641 - rrdtool dependency error when upgrading to rrdtool - 1.3.0-1.fc8.i386
Summary: rrdtool dependency error when upgrading to rrdtool - 1.3.0-1.fc8.i386
Keywords:
Status: CLOSED DUPLICATE of bug 453516
Alias: None
Product: Fedora
Classification: Fedora
Component: lm_sensors
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 16:55 UTC by Need Real Name
Modified: 2015-03-05 01:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-01 21:04:21 UTC


Attachments (Terms of Use)

Description Need Real Name 2008-07-01 16:55:59 UTC
Description of problem:
Yum crashes with the following error when doing the latest update to bring in
rrdtool - 1.3.0-1.fc8.i386:

    Error: Missing Dependency: librrd.so.2 is needed by package lm_sensors-sensord


Not really sure what is causing the problem since both the old and new versions
of rrdtool contain: librrd.so.2


Version-Release number of selected component (if applicable):
lm_sensors-2.10.6-1.fc8.i386.rpm
lm_sensors-sensord-2.10.6-1.fc8.i386.rpm
rrdtool-1.3-0.12.beta4.fc8.i386.rpm (previous working version)
rrdtool - 1.3.0-1.fc8.i386 (new upgrade causing the dependency problems)

How reproducible:
100%

Steps to Reproduce:
1. yum update
:

Comment 1 Philippe Troin 2008-07-01 18:40:46 UTC
The new rrdtool-1.3.0-1.fc8 packages only provide librrd.so.4.
lm_sensors just needs a recompile.

Phil.

Comment 2 Need Real Name 2008-07-01 20:37:59 UTC
OK - would it be possible to re-compile and put into 'updates' as soon as you can?

Also, is there really no "automated" way for the Fedora maintainers to know when
upgrades break dependencies?
Since the dependency information is in the rpm spec, I would have thought that
such a recompile would have been generated automagically.

Thanks!

Comment 3 Hans de Goede 2008-07-01 21:04:21 UTC
This bug has already been filed and an update is already on its way to the
updates repository, closing.


*** This bug has been marked as a duplicate of 453516 ***


Note You need to log in before you can comment on or make changes to this bug.