Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453628 - hwcert-client plan editing - device already in the test plan may be manually added again
Summary: hwcert-client plan editing - device already in the test plan may be manually ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness)
Version: 5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Qian Cai
QA Contact: Petr Beňas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 16:18 UTC by Greg Nichols
Modified: 2015-01-04 22:58 UTC (History)
9 users (show)

Fixed In Version: hwcert-client-1.6.4-R42
Doc Type: Bug Fix
Doc Text:
Cause: running `hwcert-client plan --add` to add a test, if the same device in the same test is already planned. Consequence: the duplicated test will be added without any warning given. Fix: in new hwcert-client version, a warning message will be given when adding a test if the same device is already planned. Result:
Clone Of:
Environment:
Last Closed: 2013-08-06 17:43:48 UTC


Attachments (Terms of Use)
patch fixing --failures option and providing more accurate feedback for --enable/--disable (deleted)
2011-07-26 15:33 UTC, Greg Nichols
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1139 normal SHIPPED_LIVE hwcert-client-1.6 bug fix and enhancement update 2013-08-06 21:42:43 UTC

Description Greg Nichols 2008-07-01 16:18:40 UTC
+++ This bug was initially created as a clone of Bug #452085 +++

In the following cases,warning/notice messages are not given
1.Disable specified test which has already disabled in the test plan by issuing
" hts plan --disable --test specified_component_name".
2.Enable specified test which has already enabled in the test plan by issuing "
hts plan --enable --test specified_component_name".
3.Add specified test which has already added in the test plan by issuing " hts
plan --add --test specified_component_name".
4.Print the failed tests' results when there is no failed tests exist by issuing
" hts print --failure "

Version-Release number of selected component (if applicable):
HTS 5.2 R16

How reproducible:
Every time

Comment 5 Greg Nichols 2011-07-26 15:33:28 UTC
Created attachment 515307 [details]
patch fixing --failures option and providing more accurate feedback for --enable/--disable


This patch fixes the --failures option in v7 1.4, and gives better feedback for the use of the --enable/--disable options, indicating when the status of the test is previously in the desired state.

Comment 27 Petr Beňas 2013-05-22 15:27:22 UTC
Verified in hwcert-client-1.6.4-49.el6.noarch.

Comment 31 errata-xmlrpc 2013-08-06 17:43:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1139.html


Note You need to log in before you can comment on or make changes to this bug.