Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453597 - new subpackage systemtap-testsuite need to be added to comps
Summary: new subpackage systemtap-testsuite need to be added to comps
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: comps
Version: 4.7
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Daniel Mach
QA Contact: Alexander Todorov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 14:37 UTC by Daniel Mach
Modified: 2008-07-24 19:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2008-0655
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 19:07:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0655 normal SHIPPED_LIVE comps bug fix and enhancement update 2008-07-23 15:44:48 UTC

Description Daniel Mach 2008-07-01 14:37:39 UTC
Description of problem:
There is new subpackage of systemtap: systemtap-testsuite
We need to update comps to get it in composes.

Comment 2 Daniel Mach 2008-07-02 13:48:16 UTC
systemtap-testsuite has been added to ppc64-compat-arch-development group


file list from compose 0701.0:
tree-AS-i386/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.i386.rpm
tree-AS-ia64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.ia64.rpm
tree-AS-ppc/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.ppc64.rpm
tree-AS-x86_64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.x86_64.rpm
tree-Desktop-i386/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.i386.rpm
tree-Desktop-x86_64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.x86_64.rpm
tree-ES-i386/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.i386.rpm
tree-ES-ia64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.ia64.rpm
tree-ES-x86_64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.x86_64.rpm
tree-WS-i386/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.i386.rpm
tree-WS-ia64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.ia64.rpm
tree-WS-x86_64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.x86_64.rpm


Comment 4 Alexander Todorov 2008-07-02 18:00:25 UTC
(In reply to comment #2)
> systemtap-testsuite has been added to ppc64-compat-arch-development group
> 

Daniel,
please clarify. ppc64 or ppc, x86 and ia64 arches? The list below shows other
arches except ppc.

> 
> file list from compose 0701.0:
> tree-AS-i386/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.i386.rpm
> tree-AS-ia64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.ia64.rpm
> tree-AS-ppc/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.ppc64.rpm
> tree-AS-x86_64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.x86_64.rpm
> tree-Desktop-i386/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.i386.rpm
> tree-Desktop-x86_64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.x86_64.rpm
> tree-ES-i386/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.i386.rpm
> tree-ES-ia64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.ia64.rpm
> tree-ES-x86_64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.x86_64.rpm
> tree-WS-i386/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.i386.rpm
> tree-WS-ia64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.ia64.rpm
> tree-WS-x86_64/RedHat/RPMS/systemtap-runtime-0.6.2-1.el4.x86_64.rpm
> 



Comment 5 Daniel Mach 2008-07-02 18:58:00 UTC
Alex, we didn't ship ppc systemtap due to kernel restrictions and we don't ship
it in rhel-4.7 as well.

I think this list only shows that everything is all right, because
systemtap-runtime is in all trees.

Comment 6 Alexander Todorov 2008-07-03 05:34:39 UTC
(In reply to comment #5)
> Alex, we didn't ship ppc systemtap due to kernel restrictions and we don't ship
> it in rhel-4.7 as well.
> 
> I think this list only shows that everything is all right, because
> systemtap-runtime is in all trees.

Daniel,
please elaborate more on that. Does that mean that systemtap-* was added to ppc
only or it was added to all arches? What is the expected result, systemtap-*
present in all arches? Which groups in comps?

Thanks.

Comment 7 Daniel Mach 2008-07-03 07:53:49 UTC
(In reply to comment #6)
> Daniel,
> please elaborate more on that. Does that mean that systemtap-* was added to ppc
> only or it was added to all arches? What is the expected result, systemtap-*
> present in all arches? Which groups in comps?
> 
> Thanks.
Alex,
as I wrote earlier, systemtap-testsuite has been added to
ppc64-compat-arch-development group, which means it has been added to ppc only.
I got report from a quality engineer, that there's something wrong with errata
file listings and there's systemtap-testsuite missing.
So I filed this bug and started to investigate what happened.
It seems that only ppc change was needed, because systemtap-testsuite is pulled
to other trees by another compose mechanism - NPLB (No Package Left Behind).

If you still need more info, we should pull developer (Frank Eigler
<fche@redhat.com>) to this discussion.

Comment 8 Alexander Todorov 2008-07-07 08:26:07 UTC
systemtap-testsuite is present in the following group:

<id>ppc64-compat-arch-development</id>
<name>ppc64 Compatibility Arch Development Support</name>
<default>false</default>
<uservisible>false</uservisible>

Since it's not default and not visible it's not possible to select this group
from the UI in anaconda. 

Daniel,
please clarify is this the desired behavior? Should this group be
visible+selectable in the UI. Was the addition to comps only needed to pull
systemtap-testsuite in the compose or it was intended that the end user will be
able to select the package manually for installation.

Comment 9 Daniel Mach 2008-07-07 09:06:14 UTC
I updated the same group, which already contained other systemtap packages to
pull systemtap-testsuite into composes.
There was no explicit request to make these packages visible in anaconda.


Comment 12 errata-xmlrpc 2008-07-24 19:07:24 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0655.html


Note You need to log in before you can comment on or make changes to this bug.