Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453595 - sound "pauses" when switching from X to TTY
Summary: sound "pauses" when switching from X to TTY
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 14:25 UTC by Dag
Modified: 2008-07-02 00:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-02 00:16:35 UTC


Attachments (Terms of Use)

Description Dag 2008-07-01 14:25:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
When using Audacious or Exaile (for example), selecting in those players "PulseAudio output", if you hit Ctrl+Alt+F1 to see the first TTY, the sound stops (it seems the players go to the "Pause" mode).
Then if you hit Alt+F7 to go back to Xorg, the sound is back and music plays back again from where it "paused".

If you try to select "Alsa output" in Audacious, it is redirected to PulsAudio by the system and sufers the same problem.

BUT if you login in one TTY as the user who is playing some sound, then the sound gets back. if you then switch to a second TTY the sound stops.
So the sound can be heard where the user playing the sound is logged in (TTY or Xorg Display).

Version-Release number of selected component (if applicable):
0.9.10-1.fc9

How reproducible:
Always


Steps to Reproduce:
1. open Audacious Music Player and configure sound output to PulseAudio
2. play a sound file
3. switch to a TTY (Ctrl+Alt+F1) while still playing, the sound pauses
4. switch back to the Xorg display where Audacious is playing: the sound will start back where it paused
5. switch back to TTY0 (sound gets paused), login as the user currently playing the sound: the sound plays back again from where it paused
6. swith to TTY1: the sound gets paused
7. switch back to Xorg: the sound is back
8. etc ...

Actual Results:
The sound was paused whenever I changed the displayed TTY or Xorg Display if the user currently playing the sound was not logged in the current displayed TTY or Display.

Expected Results:
The sound should continue playing whatever Display or TTY is currently displayed on the screen of the computer.

Additional info:

Comment 1 Lennart Poettering 2008-07-02 00:16:35 UTC
This is a feature, not a bug. If you switch to a session that is owned by a
different user, access to the audio device is given up. The magic is done via
ConsoleKit and HAL. 

This behaviour fixes a longstanding security issue that users might eavesdrop on
other users' audio streams (including recording from the mike).


Note You need to log in before you can comment on or make changes to this bug.