Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453591 - [PATCH] sg3_utils api breakage breaks compilation and running of podsleuth
Summary: [PATCH] sg3_utils api breakage breaks compilation and running of podsleuth
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: podsleuth
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 14:12 UTC by David Nielsen
Modified: 2008-09-25 00:13 UTC (History)
2 users (show)

Fixed In Version: podsleuth-0.6.2-2.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-28 08:42:52 UTC


Attachments (Terms of Use)
podsleuth debug information (deleted)
2008-07-17 20:56 UTC, David Nielsen
no flags Details
sg3_utils api patch (deleted)
2008-08-09 12:41 UTC, David Nielsen
no flags Details
version of the patch actually in the srpm (deleted)
2008-08-09 12:49 UTC, David Nielsen
no flags Details
working patch (deleted)
2008-08-09 13:52 UTC, David Nielsen
no flags Details

Description David Nielsen 2008-07-01 14:12:29 UTC
Description of problem:
My iPod stopped turning up in Banshee 1.0 and I noticed the following when
running podsleuth:

Found an iPod device, but it is not known by PodSleuth:
   Error: org.podsleuth.* properties are missing
   UDI:          /org/freedesktop/Hal/devices/volume_uuid_AEF3_A4D0
   Block Device: /dev/sdb2
   Mount Point:  /media/DAVIDS IPOD

   Cause: PodSleuth may not be installed properly, the HAL daemon may need
          to be restarted and/or the device needs to be refreshed.

SElinuix complains a whole lot.. again when inserting the iPod, so I set it to
be permissive but that did not bring about any magic solution.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.3.1-72.fc9.noarch
podsleuth-0.6.0-6.fc9.x86_64


How reproducible:
100%

Steps to Reproduce:
1. podsleuth
  
Actual results:
the above error

Expected results:
glorious feeling of being screwed by apple rather than podsleuth

Additional info:

Comment 1 David Nielsen 2008-07-04 23:44:31 UTC
Turns out this is a udev bug, which is already filed as 451320

*** This bug has been marked as a duplicate of 451320 ***

Comment 2 David Nielsen 2008-07-17 20:49:32 UTC
reopening, the bug reoccured even with udev-124-1.fc9.2.x86_64 installed. 

Comment 3 David Nielsen 2008-07-17 20:56:37 UTC
Created attachment 312081 [details]
podsleuth debug information

It turns out that podsleuth is complaining that libsgutils.so.1 is missing,
depending on sg3_utils-libs looks to be the solution?

Comment 4 David Nielsen 2008-08-09 11:57:18 UTC
I did a bit more digging on this and it turns out that sg3_utils had some api breakage which podsleuth needs to be updated for.

adding Phil Knirsch (sg3_utils maintainer) to cc for information on what changes are required.

Comment 5 David Nielsen 2008-08-09 12:00:14 UTC
Sorry, Dan Horak did the API update, add him instead of Paul.

Comment 6 David Nielsen 2008-08-09 12:41:20 UTC
Created attachment 313872 [details]
sg3_utils api patch

Stab one at the api patch, podsleuth compiles but I am still seeing the error for some reason.

updated spec and srpms:
http://dnielsen.fedorapeople.org/podsleuth.spec
http://dnielsen.fedorapeople.org/podsleuth-0.6.0-7.fc10.src.rpm

Comment 7 Dan Horák 2008-08-09 12:47:35 UTC
There was an update (in Rawhide only) of sg3_utils at the end of June and repoquery returned lsvpd, libgpod and libipoddevice as the only users of the libsgutils library. All of them were patched and rebuilt. To fix the dependency you should just recompile and relink against libsgutils2 instead of libsgutils. See http://cvs.fedoraproject.org/viewcvs/rpms/libgpod/devel/libgpod-0.6.0-sg3_utils-1.26.patch?rev=1.1&view=auto for an example.

Comment 8 David Nielsen 2008-08-09 12:49:01 UTC
Created attachment 313873 [details]
version of the patch actually in the srpm

doh, attached the wrong version.. still doesn 't work right though.

Comment 9 Dan Horák 2008-08-09 13:01:25 UTC
-        [DllImport("libsgutils.so.1")]
+        [DllImport("libsgutils.so.2")]

I think this should be 
-        [DllImport("libsgutils.so.1")]
+        [DllImport("libsgutils2.so.2")]

Comment 10 David Nielsen 2008-08-09 13:52:16 UTC
Created attachment 313877 [details]
working patch

working patch for the sg3_utils stuff, srpms above has been updated. Well spotted Dan.

Now all podsleuth complains about is 458537

Comment 11 Nigel Jones 2008-08-14 13:16:34 UTC
This package has now been orphaned, hopefully someone will be able to pick it up and resolve the reported bug soon.

Comment 12 Michel Alexandre Salim 2008-08-25 07:49:35 UTC
podsleuth unorphaned; 0.6.2 going to be pushed for F-9 updates soon.

Comment 13 Fedora Update System 2008-08-25 08:35:40 UTC
podsleuth-0.6.2-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/podsleuth-0.6.2-2.fc9

Comment 14 Fedora Update System 2008-08-25 08:36:42 UTC
podsleuth-0.6.2-2.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/podsleuth-0.6.2-2.fc8

Comment 15 Fedora Update System 2008-09-04 06:17:21 UTC
podsleuth-0.6.2-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/podsleuth-0.6.2-3.fc9

Comment 16 Fedora Update System 2008-09-04 06:18:11 UTC
podsleuth-0.6.2-3.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/podsleuth-0.6.2-3.fc8

Comment 17 Fedora Update System 2008-09-25 00:03:36 UTC
podsleuth-0.6.2-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2008-09-25 00:08:09 UTC
podsleuth-0.6.2-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2008-09-25 00:09:34 UTC
podsleuth-0.6.2-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2008-09-25 00:13:08 UTC
podsleuth-0.6.2-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.