Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453565 - Attansic L2 Gigabit network card not supported by kernel
Summary: Attansic L2 Gigabit network card not supported by kernel
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.2
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Chris Snook
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 11:46 UTC by Răzvan Sandu
Modified: 2014-06-16 11:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:06:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Răzvan Sandu 2008-07-01 11:46:27 UTC
Description of problem:


Attansic L2 Gigabit network card (integrated on Asus P5LD2-X/1333 motherboard)
is not "seen" by kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.18-92.1.6.el5 (stock kernel on a x86_64 CentOS 5.2 machine).


How reproducible:
Always.

Steps to Reproduce:
1. Install OS on a machine with the Asus P5LD2-X/1333 motherboard.
2. Reboot

  
Actual results:
Integrated LAN adapter is not recognised by kernel.

Expected results:
Integrated LAN adapter should work out of the box.

Additional info:

Machine's hardware profile, obtained via smolt:
http://www.smolts.org/client/show/pub_06b46fd9-533d-4e6f-80c7-f148ef9f0292


Output of lspci -vvv (relevant section):

02:00.0 Ethernet controller: Attansic Technology Corp. L2 100 Mbit Ethernet
Adapter (rev a0)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8233
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 16 bytes
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at ddec0000 (64-bit, non-prefetchable) [size=256K]
        Expansion ROM at ddea0000 [disabled] [size=128K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [48] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [58] Express Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
                Device: Latency L0s <4us, L1 unlimited
                Device: AtnBtn+ AtnInd+ PwrInd+
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                Device: MaxPayload 128 bytes, MaxReadReq 512 bytes
                Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s, Port 0
                Link: Latency L0s unlimited, L1 unlimited
                Link: ASPM Disabled RCB 64 bytes CommClk+ ExtSynch-
                Link: Speed 2.5Gb/s, Width x1

Comment 1 Prarit Bhargava 2008-07-07 12:09:10 UTC
Please be advised, that Bugzilla is not a support tool. It is an
Engineering and Community tool. So although all changes to Enterprise
Linux go through Bugzilla and Red Hat considers issues directly entered
into Bugzilla valuable feedback, there is no SLA around it.

If this is a production issue, please report it to your Red Hat Support contact.

Thank you.


Comment 2 Răzvan Sandu 2008-07-07 12:26:53 UTC
Hello,

Sorry, I've posted this here because the kernel is not supporting a *very
common* piece of hardware (Attansic L2 integrated network cards are present on a
large number of common motherboards nowdays - please see Asus).

So this affects a large number of users (and/or potential users), with no
special/uncommon hardware configuration.

It's especially bad for the marketing / popularity of a certain comercial
product (RHEL is *an excelent* piece of software, btw) that it cannot with all
facilities on *commodity* computers...

That's why I consider this *a bug* and I'll advise remaining so - IMHO.


Thanks a lot,
Răzvan

Comment 3 Răzvan Sandu 2008-07-07 12:29:18 UTC
"that it cannot run with all facilities" etc...

Comment 4 Răzvan Sandu 2008-07-17 07:05:08 UTC
Hello,

I'll reopen this, since I've encountered *many* mainboards with the Attansic L2
chipset these days (especially from Asus).

Unfortunately, on the x86_64 platform, I was unable to find a working driver
even in .tar.gz format (in order to compile it from source). Despite indications
given at

http://smolts.org/wiki/pci/1969/2048/1043/8233

one gets various errors during compilation...

Regards,
Răzvan


Comment 5 Chris Snook 2008-09-10 20:40:46 UTC
Atheros has become much more involved in upstream development recently, so we may be able to support this in RHEL in the near future.  Please raise this issue through your support channel to ensure proper prioritization.

Comment 6 Alan Bartlett 2009-11-01 15:18:12 UTC
(In reply to comment #4)
> Hello,
> 
> I'll reopen this, since I've encountered *many* mainboards with the Attansic L2
> chipset these days (especially from Asus).
> 
> Unfortunately, on the x86_64 platform, I was unable to find a working driver
> even in .tar.gz format (in order to compile it from source). Despite indications
> given at
> 
> http://smolts.org/wiki/pci/1969/2048/1043/8233
> 
> one gets various errors during compilation...
> 
> Regards,
> Răzvan
>   
You might like to consider using the kABI tracking kmod-atl2 package (http://elrepo.org/tiki/kmod-atl2) that is available from ELRepo (http://elrepo.org).

Comment 8 RHEL Product and Program Management 2014-03-07 13:38:21 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 9 RHEL Product and Program Management 2014-06-02 13:06:37 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Comment 10 Răzvan Sandu 2014-06-16 11:37:34 UTC
Hello,

According to my experiments, this bug seems to be fixed in CentOS 6.5.

Răzvan


Note You need to log in before you can comment on or make changes to this bug.