Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453558 - rkhunter cron job fails on fresh installs
Summary: rkhunter cron job fails on fresh installs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rkhunter
Version: el5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 10:02 UTC by Phil Anderson
Modified: 2008-07-02 10:00 UTC (History)
0 users

Fixed In Version: 1.3.2-4.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-02 10:00:18 UTC


Attachments (Terms of Use)

Description Phil Anderson 2008-07-01 10:02:43 UTC
Description of problem:
/etc/cron.daily/rkhunter fails on fresh installs as it tried to create a file in
a non-existant directory.  It tries to create a temp file in /var/rkhunter/tmp,
however that directory does not exist on fresh installs.  This is not a problem
for users who upgrade from older versions, as that directory will exist from
their old package.

Version-Release number of selected component (if applicable):
rkhinter-1.3.2-3.el5

How reproducible:
100%

Steps to Reproduce:
1. On a machine that has not had rkhunter installed before, install it
2. run /etc/cron.daily/rkhunter

  
Actual results:
mktemp: cannot create temp file /var/rkhunter/tmp/rkhcronlog.Wsmbtw6761: No such
file or directory


Expected results:
It should run

Comment 1 Kevin Fenzi 2008-07-01 15:40:27 UTC
This is fixed in 1.3.2-4.el5, which was built a bit ago, and just pushed today. 

Can you try that version and confirm it works?


Comment 2 Phil Anderson 2008-07-02 10:00:18 UTC
Latest version works for me.


Note You need to log in before you can comment on or make changes to this bug.