Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453551 - Add "Click here to use VNC" button to initial text more install screen
Summary: Add "Click here to use VNC" button to initial text more install screen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.3
Hardware: All
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Martin Sivák
QA Contact: Alexander Todorov
URL:
Whiteboard:
Depends On:
Blocks: RHEL5u3_relnotes
TreeView+ depends on / blocked
 
Reported: 2008-07-01 09:51 UTC by Martin Sivák
Modified: 2009-01-20 21:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Anaconda's Text Mode installation now presents the option of switching to Virtual Network Computing (VNC) to complete the installation.
Clone Of:
Environment:
Last Closed: 2009-01-20 21:37:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Ask the user if he wants to use vnc instead of text mode (deleted)
2008-07-15 11:31 UTC, Martin Sivák
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0164 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2009-01-20 16:05:24 UTC

Description Martin Sivák 2008-07-01 09:51:21 UTC
Enhancement for 5.3.

Our preffered way how to install headless system is over network with VNC. So
create a screen in the text mode, which will ask the user if he wants to launch
VNC mode instead.

Comment 1 RHEL Product and Program Management 2008-07-01 10:24:31 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Martin Sivák 2008-07-15 11:31:42 UTC
Created attachment 311806 [details]
Ask the user if he wants to use vnc instead of text mode

Comment 4 Martin Sivák 2008-07-15 11:39:53 UTC
Included in build 11.1.2.115

Comment 5 Alexander Todorov 2008-07-17 07:27:33 UTC
Martin,
what about when we perform the installation in kickstart mode. Will text mode be
used without any prompts? I assume so.

Thanks!

Comment 6 Denise Dumas 2008-09-12 21:19:52 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Anaconda's Text Mode installation now presents the option of switching to Virtual Network Computing (VNC) to complete the installation.  
"The VNC mode instalation offers more functionality than the text mode, would you like to use it instead?"

Note to Ryan:  David Cantrell wrote a whitepaper on how to use VNC, that we wnat to get onto th RH website as well - see
http://dcantrel.fedorapeople.org/VNC_Whitepaper/

Comment 10 Alexander Todorov 2008-09-23 07:01:16 UTC
Martin,
here're my findings:
Anaconda will show the "Would you like to use VNC?" dialog in the case when we perform fully automated kickstart install in graphical mode but for whatever reason we're forced t go into text mode (e.g. boot with console= parameter for serial console access or there's no video hardware on the machine).

I'm not sure what is the good solution here as it depends on when you check kickstart values. If anaconda will check all kickstart values and determine that it's a fully automated install then it can run into text mode because it will effectively show installation progress.
OTOH if there's information missing from the kickstart file you'll most likely want to run vnc so the user can enter the missing info.

Comment 11 Martin Sivák 2008-09-23 10:26:59 UTC
If you request graphical and we cannot start it, anaconda tries to fallback to text mode. Then we detect, that we are about to start text mode and ask the VNC question.

The problem is.. I agree that is breaks fully automated ks installs, but when you request graphical in ks and then disable it by other means, it is not very clean setup anyways.

If you want to use text mode over serial console (the described setup), why to use "graphical" command in the first place?

The logic which controls the question is this:

if vncksdata.displayMode!=DISPLAY_MODE_GRAPHICAL and vncksdata.displayMode!=None:
  flags.vncquestion = False

which means, that it really happens only when there is nothing in the ks file (and text on the boot prompt) or there is graphical in the ks file and for some reason we cannot start it, which is error, because the user requested graphical.
And I think we can suppose, that when we encounter error, the unattended instalation is not desirable.

Comment 13 Alexander Todorov 2008-09-25 06:59:33 UTC
James,
what's your take on this issue? It's causing lots of tests to timeout and we need to take some action quickly.

Comment 14 James Laska 2008-09-25 13:57:00 UTC
For 5.3 ... if using kickstart, don't prompt ... just fallback to text-mode.  Adding a timeout works as well but may just add complexity that we have to support+maintain+test for years to come.

> The problem is.. I agree that is breaks fully automated ks installs, but when
> you request graphical in ks and then disable it by other means, it is not very
> clean setup anyways.

This is very common in our and other lab setups.  We request graphical (remote KVM connected), but we want the kernel console to be a remote serial console so that we can log all output (including any unexpected prompts).  If the presence of console= is influencing the display mode preference of anaconda, perhaps we need to investigate how the display mode is established.  The presence of console= should result in text-install only if the user also supplies 'text' on the cmdline or kickstart.

Sounds like we have room for documenting expected behaviors...

We have some stuff documented in the Installation Guide already, http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Installation_Guide-en-US/s2-x86-starting-bootopts.html

Choosing a display mode:
 1) using kernel command-line (cmdline, text, vnc)
   * does serial or console= influence the result ... if so how?
 2) using kickstart (cmdline, text, vnc, graphical)

If no display mode is specified, we will try graphical, then fallback to text.

If a display mode fails to activate:
 * when doing kickstart, fallback to text
 * when not doing kickstart, prompt user for VNC or text

Thoughts/concerns?

Comment 15 Alexander Todorov 2008-09-25 14:39:32 UTC
(In reply to comment #14)
> We have some stuff documented in the Installation Guide already,
> http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Installation_Guide-en-US/s2-x86-starting-bootopts.html
> 
> Choosing a display mode:
>  1) using kernel command-line (cmdline, text, vnc)
>    * does serial or console= influence the result ... if so how?

I've heard that serial console will always force text mode. At least practice shows it does.

>  2) using kickstart (cmdline, text, vnc, graphical)
> 
> If no display mode is specified, we will try graphical, then fallback to text.
> 
> If a display mode fails to activate:
>  * when doing kickstart, fallback to text
this means we have to maintain text mode so user can enter missing information which contradicts with text mode removal ideas. Better is:

If a display mode fails to activate:
  If kickstart has all info (i.e. unattended install):
    * when doing kickstart, fallback to text or even cmdline
  else:
     * prompt user for VNC or text

Comment 16 James Laska 2008-09-25 17:00:17 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > We have some stuff documented in the Installation Guide already,
> > http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Installation_Guide-en-US/s2-x86-starting-bootopts.html
> > 
> > Choosing a display mode:
> >  1) using kernel command-line (cmdline, text, vnc)
> >    * does serial or console= influence the result ... if so how?
> 
> I've heard that serial console will always force text mode. At least practice
> shows it does.

I've heard similar things ... we need specifics on this point.  We need to tell our customers how to reliably choose a display mode.  
 
> >  2) using kickstart (cmdline, text, vnc, graphical)
> > 
> > If no display mode is specified, we will try graphical, then fallback to text.
> > 
> > If a display mode fails to activate:
> >  * when doing kickstart, fallback to text
> this means we have to maintain text mode so user can enter missing information
> which contradicts with text mode removal ideas. Better is:

There will *always* be a text-mode.  The proposed idea is to remove functionality from text-mode that adds a devel/qa/support burden.

> If a display mode fails to activate:
>   If kickstart has all info (i.e. unattended install):
>     * when doing kickstart, fallback to text or even cmdline
>   else:
>      * prompt user for VNC or text

That is the intended behavior I think works best.  We cannot change the kickstart install behavior for all of our customers that rely on the RHEL5.0 "assumptions" without a large documentation+messaging effort.

We can of course change it in Fedora in preparation for RHEL6.

In summary...

* If a user requests graphical, and it fails to activate ... feel free to prompt.

* If a user is relying on anaconda to select the display mode, and graphical fails to activate ... 
  > If kickstart ... proceed with text mode
  > If interactive ... prompt user for preference

Comment 17 Martin Sivák 2008-09-26 08:57:49 UTC
> * If a user is relying on anaconda to select the display mode, and graphical
> fails to activate ... 
>>  If kickstart ... proceed with text mode
>>  If interactive ... prompt user for preference

It should work like this from the beginning... well i guess I have an error somewhere.. 

This patch may solve it.

diff --git a/anaconda b/anaconda
index 51609e8..dd309bb 100755
--- a/anaconda
+++ b/anaconda
@@ -881,7 +881,7 @@ if __name__ == "__main__":
             got_bad_edid = True
             opts.display_mode = 't'
 
-    if opts.display_mode == 't' and graphical_failed and not opts.ksfile:
+    if opts.display_mode == 't' and graphical_failed and not anaconda.isKickstart:
         ret = vnc.askVncWindow()
         if ret != -1:
             opts.display_mode = 'g'

The updates image for it is at http://msivak.fedorapeople.org/anaconda/vncq.img

Comment 18 Martin Sivák 2008-09-26 13:19:23 UTC
Ok, after debugging session with Alex, we now have the solution in git repo and it will be in the next (11.1.2.132) build.

And for the other question: The text mode is indeed set by loader, when the serial is requested (loader2/loader.c:1510).

Comment 20 Don Domingo 2008-11-18 23:16:24 UTC
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,5 +1 @@
-Anaconda's Text Mode installation now presents the option of switching to Virtual Network Computing (VNC) to complete the installation.  
+Anaconda's Text Mode installation now presents the option of switching to Virtual Network Computing (VNC) to complete the installation.-"The VNC mode instalation offers more functionality than the text mode, would you like to use it instead?"
-
-Note to Ryan:  David Cantrell wrote a whitepaper on how to use VNC, that we wnat to get onto th RH website as well - see
-http://dcantrel.fedorapeople.org/VNC_Whitepaper/

Comment 22 Vadym Chepkov 2008-12-13 19:51:02 UTC
This options was added to Fedora 10 and now it is impossible to perform unattended text mode installation.
If I specifically put text mode into the anaconda's command line it shouldn't pause installation and ask if I want to use VNC instead

Comment 23 Alexander Todorov 2008-12-15 09:35:09 UTC
Vadym,
this bug is filed against Red Hat Enterprise Linux 5 not Fedora. If you're seeing the issue with F10 please file another bug. You can add a link to this bug saying that it was fixed in RHEL.

Comment 25 errata-xmlrpc 2009-01-20 21:37:15 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html


Note You need to log in before you can comment on or make changes to this bug.