Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453536 - Support for ttl and message expiration
Summary: Support for ttl and message expiration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 1.0
Hardware: All
OS: Linux
urgent
medium
Target Milestone: 1.1
: ---
Assignee: Gordon Sim
QA Contact: Kim van der Riet
URL:
Whiteboard:
: 448589 (view as bug list)
Depends On:
Blocks: 471311
TreeView+ depends on / blocked
 
Reported: 2008-07-01 08:53 UTC by Gordon Sim
Modified: 2009-02-04 15:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-04 15:35:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:0035 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 1.1 Release 2009-02-04 15:33:44 UTC

Description Gordon Sim 2008-07-01 08:53:10 UTC
If a ttl is set messages should be expired from queues after the desired time.

See https://issues.apache.org/jira/browse/QPID-528

Comment 1 Gordon Sim 2008-10-02 15:08:05 UTC
*** Bug 448589 has been marked as a duplicate of this bug. ***

Comment 2 Gordon Sim 2008-10-14 11:22:03 UTC
Committed final part of this (for now at least!) in r704461. Tests exist in c++ and python (cpp/src/tests/ClientSessionTest::testExpirationOnPop and cpp/src/tests/ClientSessionTest::testPeriodicExpiration and python/tests_0-10/message/test_ttl).

Messages are checked for expiry before dispatching them to subscribers. Epired messages are dropped on dequeue and periodically all expired messages are expunged  unless the rate of dequeues since last purge is higher than one per second). The rate of the periodic purging of expired messages can be configured via the --queue-clean-interval option to qpidd.

Comment 4 Frantisek Reznicek 2008-11-24 15:07:35 UTC
C++ tests mentioned above exists and passing.
Feature implemented.
->VERIFIED

Comment 6 errata-xmlrpc 2009-02-04 15:35:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0035.html


Note You need to log in before you can comment on or make changes to this bug.