Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453531 - Unable to install when NIC is not managed by NetworkManager
Summary: Unable to install when NIC is not managed by NetworkManager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 08:35 UTC by Daniel Berrange
Modified: 2008-08-18 09:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-18 09:07:00 UTC


Attachments (Terms of Use)

Description Daniel Berrange 2008-07-01 08:35:07 UTC
Description of problem:
On servers running virtualization it is typical to setup network cards in a
bridged / bonded / vlan configuration. This isn't something supported by
NetworkManager, so all the /etc/sysconfig/network-scripts/ifcfg-XXXX files are
set with


NM_CONTROLLED=no

This stops NetworkManager from attempting to configure them & instead allows the
traditional network init scripts to deal with the problem.

If I attempt to use PacakgeKit to install new software on a box configured in
this way, it allows me to search for apps & select them for install, but when it
actually attempts to perform the install it throws an error

  "No network connection available

   Cannot install when offline"

Which is clearly wrong because my network works just fine.

Version-Release number of selected component (if applicable):
PackageKit-0.1.12-13.20080522.fc9.i386
NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386


How reproducible:
Always

Steps to Reproduce:
1. Configure all NICs the traditional way, and add  NM_CONTROLED=no to their config
2. Attempt to install an RPM with PackageKit
3.
  
Actual results:
Refuses to even try to download & install

Expected results:
Downloads and installs the package

Additional info:

Comment 1 Daniel Berrange 2008-07-01 09:58:20 UTC
BTW, in this setup I have both the 'NetworkManager' and 'network' init script
services running at the same time. I'm simply using the NM_CONTROLLED={no|yes} 
config var to determine which NICs NetworkManager touches

Comment 2 Richard Hughes 2008-07-04 09:37:11 UTC
Could you give the packages in rawhide a go please? I think I've fixed all the
network issues now. You can rebuild the srpm for F9 if you wish. Thanks dude.

Comment 3 Richard Hughes 2008-08-04 08:42:14 UTC
Do the PackageKit rpms in fedora-updates fix this issue? Cheers dude.

Comment 4 Nils Philippsen 2008-08-04 10:15:45 UTC
The packages with which I saw this are:

gnome-packagekit-0.2.3-9.fc9.x86_64
PackageKit-libs-0.2.3-6.fc9.x86_64
PackageKit-0.2.3-6.fc9.x86_64
yum-packagekit-0.2.3-6.fc9.x86_64

I'll give the 2.4.1 ones in updates-testing a whirl...

Comment 5 Nils Philippsen 2008-08-04 10:45:18 UTC
This one doesn't seem to work consistently...

Just for the record, I have:

UseNetworkManager=false
UseNetworkHeuristic=true

and use HTTP/FTP proxies.

If I go to "System/Administration/Update System" and click on "Refresh", I get one dialog with "No network connection available", another "Refresh package lists" which stays on "Waiting for other tasks". If I close the first, both dialogs vanish. Nothing gets refreshed ("Last refresh: A few days ago").

If I click on "Update System", it updates the system, though.

Comment 6 Daniel Berrange 2008-08-05 08:44:06 UTC
I updated to

PackageKit-0.2.4-1.fc9.i386

This only partially fixes the problem.

If I have NetworkManager service stopped, and network initscripts active, then everything works fine.

If I have both NetworkManager & network initscript active, but with my currently online NIC managed by the init scripts, then PackageKit still thinks there's no network connection. So you can't use it in a hybrid solution where you're controlling which NICs are managed based on the  NM_CONTROLLED=no config setting.

Comment 7 Richard Hughes 2008-08-05 10:10:11 UTC
When NM is up, and you have UseNetworkManager = false and UseNetworkHeuristic = true in the config file, what's the output of cat /proc/net/route?

Thanks.

Comment 8 Nils Philippsen 2008-08-05 12:29:06 UTC
This is /proc/net/route (regardless of whether NM is running or not):

nils@wombat:~> cat /proc/net/route 
Iface	Destination	Gateway 	Flags	RefCnt	Use	Metric	Mask		MTU	Window	IRTT                                                       
ppp0	01004158	00000000	0005	0	0	0	FFFFFFFF	0	0	0                                                                               
eth0	0000000A	00000000	0001	0	0	0	00FFFFFF	0	0	0                                                                               
eth1	0001000A	00000000	0001	0	0	0	00FFFFFF	0	0	0                                                                               
eth1	0000FEA9	00000000	0001	0	0	0	0000FFFF	0	0	0                                                                               
ppp0	00000000	00000000	0001	0	0	0	00000000	0	0	0

Comment 9 Richard Hughes 2008-08-05 12:51:32 UTC
Right, so that's the problem. The UseNetworkHeuristic code looks for adaptors with a non-zero gateway, and all yours in /proc/net/route have no gateway. Do commands like ping www.bbc.co.uk work, or is everything tunneled via a proxy?

Comment 10 Nils Philippsen 2008-08-05 15:07:04 UTC
Everything works, nothing is tunneled: this is a PPP (point-to-point) Internet connection (xDSL):

Iface Destination Gateway  Flags RefCnt Use Metric Mask  MTU Window IRTT
ppp0 01004158 00000000 0005 0 0 0 FFFFFFFF 0 0 0                                
...
ppp0 00000000 00000000 0001 0 0 0 00000000 0 0 0

first line is the host route to my peer (i.e. provider), last line is the default route, where no explicite gateway is necessary due it being point-to-point (i.e. only one host on the other end). Perhaps you should check for a zero destination, AFAIK that's the way to spot default routes.

Comment 11 Fedora Update System 2008-08-06 08:21:57 UTC
PackageKit-0.2.4-3.fc9 has been submitted as an update for Fedora 9

Comment 12 Nils Philippsen 2008-08-06 09:47:47 UTC
PackageKit-0.2.4-3.fc9 works for me with default settings as well as with UseNetworkManager=false and proxies.

Comment 13 Richard Hughes 2008-08-06 10:29:24 UTC
Cool, thanks for the quick testing. If it breaks again, please re-open. Thanks.

Comment 14 Fedora Update System 2008-08-07 23:49:42 UTC
PackageKit-0.2.4-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7001

Comment 15 Fedora Update System 2008-08-12 18:20:08 UTC
PackageKit-0.2.4-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.