Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453522 - virt-manager does not remember file size for storage file when going back
Summary: virt-manager does not remember file size for storage file when going back
Keywords:
Status: CLOSED DUPLICATE of bug 452468
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Daniel Berrange
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 07:53 UTC by Alexander Todorov
Modified: 2009-12-14 21:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-09 11:33:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Todorov 2008-07-01 07:53:41 UTC
Description of problem:
The chosen file size for storage image is reset back to default (4000 MB) when
going back in virt-manager UI.

Version-Release number of selected component (if applicable):
virt-manager-0.5.3-8.el5

How reproducible:
Always

Steps to Reproduce:
1. Run virt-manager and create a new guest (FV in my case)
2. At "Assigning storage space" select "Simple file" and change the default size
3. Proceed to the next screen (or next 2 screens)
4. Go back at the "Assigning storage space" screen
  
Actual results:
File size is reset to default (4000 MB)

Expected results:
File size is the same as entered by the user

Additional info:
I assume that this is caused by design, i.e. when the screen shows up the UI
fills in a default value for the file size (which in this case could be
overwriting the previous value). This is causing problems with usability for the
end user. When one configures a guest and goes Back/Forward to modify settings
one expects that everything they do not modify stays the same. In particular
this has caused a few "not enough disk space" errors for me.

Comment 1 RHEL Product and Program Management 2008-07-01 08:20:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Alexander Todorov 2008-07-09 11:33:54 UTC

*** This bug has been marked as a duplicate of 452468 ***


Note You need to log in before you can comment on or make changes to this bug.