Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453516 - lm_sensors-sensord needs update to install with updated rrdtool
Summary: lm_sensors-sensord needs update to install with updated rrdtool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lm_sensors
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 453641 453737 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 07:11 UTC by J. Randall Owens
Modified: 2015-03-05 01:20 UTC (History)
5 users (show)

Fixed In Version: 2.10.6-2.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-02 06:32:01 UTC


Attachments (Terms of Use)

Description J. Randall Owens 2008-07-01 07:11:32 UTC
Description of problem:
rrdtool was recently updated, and since lm_sensors-sensord depends on the
(former) particular version of rrdtool (1.3-0.14.beta4), smart (& presumably yum
& PackageKit?) ask to uninstall it to install the new rrdtool (1.3.0-1)

Version-Release number of selected component (if applicable):
lm_sensors-sensord-3.0.1-5.fc9

How reproducible:
Attempt to upgrade to latest Fedora Updates, while the lm_sensors packages are
already installed

Steps to Reproduce:
1. smart install lm_sensors-sensord rrdtool-1.3-0.14.beta4
2. smart upgrade
  
Actual results:
smart asks to uninstall the lm_sensors-sensord package to upgrade rrdtool

Expected results:
smart upgrades rrdtool and possibly the lm_sensors packages, without
uninstalling any of them

Additional info:
I'll do a repackage of the lm_sensors packages as soon as rrdtool etc. finish
upgrading, and see whether all that's needed is a package rebuild & release
bump.  Guessing by the versionless "BuildRequires: rrdtool-devel" in the
specfile, that's probably all.

Comment 1 J. Randall Owens 2008-07-01 07:12:55 UTC
Oh, and I did check testing to see if there were any new lm_sensors packages
coming down the pipe, but didn't find anything there yet.

Comment 2 J. Randall Owens 2008-07-01 07:28:07 UTC
Ah, it's not just the bump in the release number of rrdtools that did it.  They
now provide librrd(_th)?.so.4 instead of librrd(_th)?.so.2 like the older
packages.  And lm_sensors-sensorsd requires librrd.so.2, of course.

Comment 3 Hans de Goede 2008-07-01 07:32:53 UTC
Thanks for reporting, AFAIK a rebuild is all thats needed (already done in
rawhide) I'll go submit a rebuild now and then issue an update.

Then I'll go hit the rddtool maintainer with the cluebat (repeatedly) teaching
him not todo ABI / soname breaking updates in released Fedora versions unless
there is a _really_ _really_ good reason, and teach him to coordinate with
dependend packages in the _really_ _really_ good reason scenario.




Comment 4 J. Randall Owens 2008-07-01 08:22:25 UTC
Yep, I've mocked my own now, it installs fine.

And given your reaction, you might like to know I've just filed bugs for two
other (sets of) packages, ganglia (bug 45315) and collectd (bug 453529).  A
little more fuel for the cluebat.

Comment 5 J. Randall Owens 2008-07-01 08:29:05 UTC
Oops, that's "ganglia (bug 453515)".

Comment 6 Fedora Update System 2008-07-01 09:48:42 UTC
lm_sensors-3.0.1-6.fc9 has been submitted as an update for Fedora 9

Comment 7 Fedora Update System 2008-07-01 11:49:44 UTC
lm_sensors-3.0.2-1.fc9 has been submitted as an update for Fedora 9

Comment 8 Fedora Update System 2008-07-01 11:51:47 UTC
lm_sensors-2.10.6-2.fc8 has been submitted as an update for Fedora 8

Comment 9 Hans de Goede 2008-07-01 21:04:22 UTC
*** Bug 453641 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2008-07-02 06:31:58 UTC
lm_sensors-2.10.6-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2008-07-02 06:32:30 UTC
lm_sensors-3.0.2-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Hans de Goede 2008-07-02 09:39:47 UTC
*** Bug 453737 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2008-07-26 06:02:06 UTC
lm_sensors-3.0.2-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.