Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453504 - RA perl scripts won't compile on Fedora 9
Summary: RA perl scripts won't compile on Fedora 9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Dogtag Certificate System
Classification: Retired
Component: RA
Version: 1.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Matthew Harmsen
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 450345 443788
TreeView+ depends on / blocked
 
Reported: 2008-07-01 04:09 UTC by Andrew Bartlett
Modified: 2015-01-06 01:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-22 23:29:05 UTC


Attachments (Terms of Use)
Patch to fix the problem, per advise of #perl on irc.freenode.net (deleted)
2008-07-01 04:09 UTC, Andrew Bartlett
no flags Details | Diff
Fix for empty namespace issue in Perl on Fedora 9 (deleted)
2008-07-02 00:38 UTC, Matthew Harmsen
no flags Details
Fix for empty namespace issue in Perl on Fedora 9 (deleted)
2008-11-23 03:17 UTC, Matthew Harmsen
no flags Details

Description Andrew Bartlett 2008-07-01 04:09:27 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Start RA on Fedora 9
2. eg service pki-ra start
3.
  
Actual results:
Failure to start

Expected results:
Start successfully

Additional info:
Due to changes in perl, documented in 2nd para of:

http://perldoc.perl.org/functions/package.html

Comment 1 Andrew Bartlett 2008-07-01 04:09:28 UTC
Created attachment 310638 [details]
Patch to fix the problem, per advise of #perl on irc.freenode.net

Comment 2 Andrew Bartlett 2008-07-01 04:23:08 UTC
Naturally, this occurs in all of the instances of Modutil.pm

Comment 3 Matthew Harmsen 2008-07-02 00:38:57 UTC
Created attachment 310741 [details]
Fix for empty namespace issue in Perl on Fedora 9

Comment 4 Matthew Harmsen 2008-11-23 03:17:33 UTC
Created attachment 324422 [details]
Fix for empty namespace issue in Perl on Fedora 9

Comment 5 Jack Magne 2008-11-23 03:21:15 UTC
Attachment (id=324422) +jmagne.

Comment 6 Matthew Harmsen 2008-11-23 03:23:11 UTC
svn status

M      linux/ra/pki-ra.spec
M      linux/tps/pki-tps.spec
M      base/ra/lib/perl/PKI/RA/Modutil.pm
M      base/tps/lib/perl/PKI/TPS/Modutil.pm

svn commit

Sending        base/ra/lib/perl/PKI/RA/Modutil.pm
Sending        base/tps/lib/perl/PKI/TPS/Modutil.pm
Sending        linux/ra/pki-ra.spec
Sending        linux/tps/pki-tps.spec
Transmitting file data ....
Committed revision 143.

Comment 7 Kashyap Chamarthy 2009-06-10 16:41:14 UTC
Verified. RA starts/restarts fine, and no perl-script compile errors are thrown.


Note You need to log in before you can comment on or make changes to this bug.