Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453499 - RFE: provide conditional requires for yum
Summary: RFE: provide conditional requires for yum
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Fedora Packaging Toolset Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 510916 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 01:37 UTC by Jens Petersen
Modified: 2015-11-13 10:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-13 10:42:41 UTC


Attachments (Terms of Use)

Description Jens Petersen 2008-07-01 01:37:13 UTC
Description of problem:
In distros it is often necessary to have packages that only get installed
when certain other packages are installed or going to be installed.
For example langpacks for certain packages or input method support,
or cross-package support and features.  It would also be important
to people upgrading and getting new features installed that they might
otherwise not be aware of.

Steps to Reproduce:
1. Upgrade from F8 XFCE desktop to F9 with scim installed 
2. try to use scim in F9 xfce
  
Actual results:
2. Does not work since imsettings-xfce (new package) did not get installed.
Can't fix problem in comps, or yum without some hack.


Expected results:
2. If xfce-desktop could have a conditional dependency on imsettings-xfce
if imsettings is installed this would solve the problem and an update
could be released to fix it.

Additional info:
This would correspond to (and might remove the need for) condtional packages in
comps.

Comment 1 Jens Petersen 2008-10-28 08:05:34 UTC
Currently thinking this could be handled by a yum plugin and language metapackages.

Comment 2 Panu Matilainen 2009-07-14 09:50:02 UTC
*** Bug 510916 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Admin XMLRPC Client 2012-04-13 23:13:17 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Fedora Admin XMLRPC Client 2012-04-13 23:14:16 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Florian Festi 2015-11-13 10:42:41 UTC
The new rich dependencies are exactly this. Sorry, that it took so long.


Note You need to log in before you can comment on or make changes to this bug.