Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453498 - Creating an RPM fails for 2.6.25.6 when Xen is selected without optimize size
Summary: Creating an RPM fails for 2.6.25.6 when Xen is selected without optimize size
Keywords:
Status: CLOSED DUPLICATE of bug 126342
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 01:34 UTC by stanl
Modified: 2008-07-03 05:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-01 03:22:39 UTC


Attachments (Terms of Use)

Description stanl 2008-07-01 01:34:33 UTC
Description of problem:
While compiling the latest redhat kernel from the src RPM, if Xen is selected in
make menuconfig and optimize for size is not, the build fails with Error 1 and
Error 2 because it can't resolve the symbol __udivdi3 in /xen/time.c

Version-Release number of selected component (if applicable):
2.6.25.6-55 src RPM

How reproducible:
Every time.


Steps to Reproduce:
1.install linux kernel 2.6.25.6-55 from fedora 9
2.make menuconfig, make sure xen enabled, optimize for size is disabled
3.make binrpm-pkg
4.Everything will work until it is time to create the package, then it will
complain that it can't resolve __udivdi3
  
Actual results:
Error 1
Error 2


Expected results:
Exit 0, with package created under RPMS in home rpmbuild directory.


Additional info:

Comment 1 Dave Jones 2008-07-01 03:22:39 UTC

*** This bug has been marked as a duplicate of 126342 ***

Comment 2 Chuck Ebbert 2008-07-03 03:29:04 UTC
BTW this is fixed in 2.6.26...

Comment 3 stanl 2008-07-03 05:03:20 UTC
Thanks for the heads up.


Note You need to log in before you can comment on or make changes to this bug.