Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453492 - Upgrade to trac 0.11.x (0.11.2)
Summary: Upgrade to trac 0.11.x (0.11.2)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: trac
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 453942 454871 457572 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 00:31 UTC by Brian G. Anderson
Modified: 2009-03-09 18:31 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-18 16:50:36 UTC


Attachments (Terms of Use)

Description Brian G. Anderson 2008-07-01 00:31:43 UTC
Description of problem:
The latest stable release of trac is 0.11.  Many plugins at the trac site are
only for 0.11.  Please release an updated package and plugins.

Version-Release number of selected component (if applicable):
trac.noarch                              0.10.4-2.fc9

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeffrey C. Ollie 2008-07-01 03:44:01 UTC
With the help of Ryan Lynch I've been working on getting 0.11 in shape for
rawhide.  Whether I push this to F-9 or any other version remains to be seen
because of the database/environment updates required.

Comment 2 Johan Kok 2008-07-05 08:58:57 UTC
*** Bug 453942 has been marked as a duplicate of this bug. ***

Comment 3 Jeffrey C. Ollie 2008-07-10 13:49:58 UTC
*** Bug 454871 has been marked as a duplicate of this bug. ***

Comment 4 Bas Mevissen 2008-07-11 01:36:33 UTC
Would love to go to 0.11 due to new features regarding finer grained access
control and more integrated plug-ins and (real) database support.

Due to the immaturity of trac in general, a trac<version>-* scheme would be
preferably. That way, people can decide what version to run for themselves. My
guess is that during the life time of F9, there will be another incompatible
major update.

Anyway, would be already very happy to see a 0.11 package in RH. I'll install it
on a production system if the package works well enough!


Comment 5 Levente Farkas 2008-07-11 10:15:21 UTC
will trac-0.11 run on rhel/centos-5? doesn't 0.11 require python 2.5?

Comment 6 Jeffrey C. Ollie 2008-07-11 12:16:34 UTC
Jesse Keating has been testing the trac 0.11 upgrade on rhel5 in preparation for
upgrading Fedora Hosted, so it doesn't appear to require Python 2.5.


Comment 7 Harshad RJ 2008-08-01 15:33:18 UTC
*** Bug 457572 has been marked as a duplicate of this bug. ***

Comment 8 Harshad RJ 2008-08-04 05:55:20 UTC
Jefferey et al,

Can you mention what the dependencies for 0.11 are? The Changelog on the Trac website doesn't mention any backend changes, but it may not be complete.

If there are indeed some dependencies, we can then add them in the "blocks" field of this bug report, to help track progress.

Thanks,
Harshad

Comment 9 Anthony Messina 2008-08-04 07:44:29 UTC
The one thing I'm looking for is to use PostgreSQL in Fedora 9, which apparently needs: http://trac.edgewall.org/changeset/6512

Comment 10 Jeffrey C. Ollie 2008-08-04 12:31:42 UTC
As far as I know the all of the dependencies are taken care of already.  Jesse Keating has been doing most of the work to get the package upgraded but he's been busy trying to get the F10 Alpha built.

Comment 12 Jose Pedro Oliveira 2008-10-11 13:56:38 UTC
Hi, are there any recent developments on the packaging of trac 0.11.x?

Comment 13 Jose Pedro Oliveira 2008-11-09 19:06:04 UTC
Any news on the trac update (0.10.x --> 0.11.x)?

FYI: Trac 0.11.2 is already available.

Release notes:
http://trac.edgewall.org/browser/tags/trac-0.11.2/RELEASE

Comment 14 Jeffrey C. Ollie 2008-11-18 16:50:36 UTC
I've build 0.11.2.1 for F11:

http://koji.fedoraproject.org/koji/taskinfo?taskID=937926

Once we have the kinks sorted out on F11 we can discuss pushing 0.11.x as an update for previous releases.

Comment 15 Guillaume Kulakowski 2009-03-09 18:31:49 UTC
Hi,

any build for F9/10/EPEL5 ?


Note You need to log in before you can comment on or make changes to this bug.