Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453491 - Error when creating vm with virt-manager
Summary: Error when creating vm with virt-manager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 331511 458734 472099 473158 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-01 00:29 UTC by James Morris
Modified: 2009-02-16 14:52 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-16 14:52:13 UTC


Attachments (Terms of Use)

Description James Morris 2008-07-01 00:29:34 UTC
Description of problem:

I get an error when trying to create a vm with virt-manager with an up to date
F9 system.

Version-Release number of selected component (if applicable):

virt-manager-0.5.4-4.fc9.x86_64

How reproducible:

always


Steps to Reproduce:
1. run virt-manager
2. try to configure kvm vm
  
Actual results:

Dialog:

Unable to complete install: 'virDomainCreateLinux() failed internal error Timed
out while reading monitor startup output'

Unable to complete install '<class 'libvirt.libvirtError'>
virDomainCreateLinux() failed internal error Timed out while reading monitor
startup output
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 651, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 845, in
start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 866, in
_do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 833, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed internal error Timed out while
reading monitor startup output
'


Expected results:

No error.

Additional info:

After that happened, I closed the error dialog and the installation seems to
keeps going...

Comment 1 Cole Robinson 2008-08-28 19:54:43 UTC
That error message basically means something went funky when kicking off the qemu command line. Do you still see this or was it a one off occasion? If you can reproduce it, can you attach /var/log/libvirt/qemu/{guestname}.log after the error message appears? Thanks

Comment 2 James Morris 2008-08-28 23:10:09 UTC
I'm still seeing it on a current F9 system.

Unable to complete install '<class 'libvirt.libvirtError'> virDomainCreateLinux() failed internal error Timed out while reading monitor startup output
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 651, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 845, in start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 866, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 841, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed internal error Timed out while reading monitor startup output
'

After that, it keeps installing anyway, even after issuing the error dialog.

Here's the contents of that log file:
----

/usr/bin/qemu-kvm -S -M pc -m 512 -smp 1 -name v1 -monitor pty -no-reboot -boot d -drive file=/var/lib/libvirt/images/v1-1.img,if=ide,index=0 -drive file=/dev/sr0,if=ide,media=cdrom,index=2 -net nic,macaddr=00:16:3e:5b:f8:35,vlan=0 -net tap,fd=14,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -vnc 127.0.0.1:0 -k en-us 
char device redirected to /dev/pts/13
char device redirected to /dev/pts/14
iESC[KESC[DinESC[KESC[DESC[DinfESC[KESC[DESC[DESC[DinfoESC[KESC[DESC[DESC[DESC[Dinfo ESC[KESC[DESC[DESC[DESC[DESC[Dinfo cESC[KESC[DESC[DESC[DESC[DESC[DESC[Dinfo cpESC[KESC[DESC[DESC[DESC[DESC[DESC[DESC[Dinfo cpuESC[KESC[DESC[DESC[DESC[DESC[DESC[DESC[DESC[Dinfo cpusESC[K
* CPU #0: pc=0x00000000000ffff0 thread_id=16021^McESC[KESC[DcoESC[KESC[DESC[DconESC[KESC[DESC[DESC[DcontESC[K
----

Btw, why is this full of non-human readable data?

Comment 3 Cole Robinson 2008-09-04 12:30:08 UTC
The unreadable output is the result of reading data from the qemu monitor: we should try and sanitize it at the libvirt level.

I'm not sure though what is causing the timeout, there doesn't seem to be anything wrong with the bootup. Other people have reported similar issues and my guess is that it's load dependent: when you create the vm do you specify a new disk so that virt-manager allocates it?

Maybe the fix is just set the timeout from 3 seconds to 10: a true timeout shouldn't be a common occurence, and if the qemu command errors it will exit immediately anyways so we won't hit the timeout issue.

Comment 4 James Morris 2008-09-04 13:34:05 UTC
In this case, I believe I created a new disk during the installation, probably whatever the default is.

Comment 5 Cole Robinson 2008-11-26 16:30:55 UTC
*** Bug 331511 has been marked as a duplicate of this bug. ***

Comment 6 Cole Robinson 2008-12-01 20:03:07 UTC
*** Bug 458734 has been marked as a duplicate of this bug. ***

Comment 7 Cole Robinson 2008-12-01 20:37:06 UTC
*** Bug 472099 has been marked as a duplicate of this bug. ***

Comment 8 Cole Robinson 2008-12-01 21:51:15 UTC
*** Bug 473158 has been marked as a duplicate of this bug. ***

Comment 9 Cole Robinson 2008-12-01 21:53:23 UTC
Okay, I'm pretty sure I figured this out. The reason this is timing out is because we are installing off the cd drive, and the qemu monitor is unresponsive while the media is spinning up.

I think the only thing to do is just lengthen the timeout value at the libvirt level, which I'm going to test now. Re-assigning to libvirt.

Comment 10 Cole Robinson 2008-12-07 16:41:50 UTC
Okay, a fix was committed upstream:

http://git.et.redhat.com/?p=libvirt.git;a=commit;h=be1c939a7533e18eb58711f947ea46dcd44473d5

This is in libvirt 0.5.1 which should be in F9 and F10 updates-testing (if not now, then soon). Moving this to ON_QA.

Comment 11 Cole Robinson 2009-02-16 14:52:13 UTC
Fixed in 0.5.1, so closing.


Note You need to log in before you can comment on or make changes to this bug.