Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453487 - langpacks need updating to current default CIJK fonts
Summary: langpacks need updating to current default CIJK fonts
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 453868 453869 (view as bug list)
Depends On:
Blocks: F10Target
TreeView+ depends on / blocked
 
Reported: 2008-06-30 23:35 UTC by Jens Petersen
Modified: 2008-07-07 12:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-07 12:44:38 UTC


Attachments (Terms of Use)
openoffice.org.spec-fonts-update.patch (deleted)
2008-07-02 08:50 UTC, Jens Petersen
no flags Details | Diff

Description Jens Petersen 2008-06-30 23:35:27 UTC
Description of problem:
In Fedora 8 we made some major repackaging changes to the fonts for ja, ko, zh
and Indic
and also ar and he.  The fonts-* packages were split up into individual packages
named after their upstream project.  Also in F9 we changed the default font for
Japanese to VLGothic-fonts.  In F10 we are removing most of the remaining
fonts-* meta
packages and also introducing a new default font for Korean (un-fonts-core is
currently
under package review).

So in this bug I would like to describe the required changes.  If you prefer
separate
fonts for the above we could also make this a tracking bug but I think that should
hopefully not be necessary.

More details to come as necessary (I guess the fonts in the @fonts comps group
are a pretty good indication of the default fonts though).

Comment 1 Caolan McNamara 2008-07-01 12:23:21 UTC
Can you just tell me what fonts packages you want for which langpacks and I can
do it immediately.

Comment 2 Jens Petersen 2008-07-02 08:50:54 UTC
Created attachment 310769 [details]
openoffice.org.spec-fonts-update.patch

Here is a patch which should provide the necessary changes.

Comment 3 Jens Petersen 2008-07-02 08:52:14 UTC
Though now that we install all those fonts by default anyway, I would rather
openoffice.org langpacks didn't really require any fonts explicitly.

Comment 4 Caolan McNamara 2008-07-02 11:47:38 UTC
Its a fine theory to not require any fonts at all, but history shows that a most
terrible amount of whining and general bitching about the stupidity of
OpenOffice.org occurs without a guarantee of at least one font installed which
can cover the desired range :-)

Comment 5 Jens Petersen 2008-07-03 01:25:16 UTC
*** Bug 453868 has been marked as a duplicate of this bug. ***

Comment 6 Caolan McNamara 2008-07-03 13:40:36 UTC
*** Bug 453869 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.