Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453486 - grub in F8 is newer than F9; RPM version issue
Summary: grub in F8 is newer than F9; RPM version issue
Keywords:
Status: CLOSED DUPLICATE of bug 469486
Alias: None
Product: Fedora
Classification: Fedora
Component: grub
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 22:59 UTC by Stephen Warren
Modified: 2009-03-01 09:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-01 09:12:44 UTC


Attachments (Terms of Use)

Description Stephen Warren 2008-06-30 22:59:59 UTC
I just performed an upgrade from Fedora 8 to Fedora 9 using preupgrade.

I had this version of grub installed:
grub-0.97-33.1.fc8.i386

yum did not upgrade this rpm to the Fedora 9 version, because the pushed F9
version is older than the F8 version:
grub-0.97-33.fc9.i386.rpm

It seems that the F8 version went from 33.fc8 to 33.1.fc8, which is newer than
F9's 33.fc9. F8's version should have been built as 33.fc8.1 instead.

To solve this, F9's grub should be rebuilt as 34.fc9 and pushed.

Comment 1 Stephen Warren 2008-07-11 17:48:13 UTC
Hmm. That said, this won't help fix preupgrade, or the upgrade-via-F9-release-cd
path, since they both use the initial F9 release RPMs that can't be changed.

Can grub in F9 be down-graded to and older name-version-release? I guess that's
not possible for people who've already 'yum update'd...

Shouldn't Koji/Bodhi enforce the NVR ordering between releases? For some reason,
I thought it did...



Comment 2 lexual 2009-03-01 09:12:44 UTC

*** This bug has been marked as a duplicate of bug 469486 ***


Note You need to log in before you can comment on or make changes to this bug.