Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453481 - [openjdk] OOo writer crashes when using wizards
Summary: [openjdk] OOo writer crashes when using wizards
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 9
Hardware: powerpc
OS: Linux
low
low
Target Milestone: ---
Assignee: Lillian Angel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 22:19 UTC by Ian Chapman
Modified: 2008-11-06 14:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-06 14:44:40 UTC


Attachments (Terms of Use)
Trace of crash from OO writer (deleted)
2008-06-30 22:19 UTC, Ian Chapman
no flags Details
Java error log related to oo crash. (deleted)
2008-06-30 22:25 UTC, Ian Chapman
no flags Details
mapped stack (deleted)
2008-07-01 13:12 UTC, Caolan McNamara
no flags Details

Description Ian Chapman 2008-06-30 22:19:36 UTC
Description of problem:

OO writer crashes when a wizard eg the Letter wizard is used.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.4.1-17.4.fc9.ppc
java-1.6.0-openjdk-1.6.0.0-0.15.b09.fc9.ppc

How reproducible:


Steps to Reproduce:
1. Run open office writer
2. Select File -> Wizards -> Letter
3.
  
Actual results:

Instantly crashes

Expected results:

Should open the letter wizard

Additional info:

Comment 1 Ian Chapman 2008-06-30 22:19:36 UTC
Created attachment 310623 [details]
Trace of crash from OO writer

Comment 2 Ian Chapman 2008-06-30 22:25:42 UTC
Created attachment 310625 [details]
Java error log related to oo crash.

Comment 3 Caolan McNamara 2008-07-01 12:34:30 UTC
I wonder if this also happens if you use libgcj ? 

Assuming that both are installed, you can tell OOo to use the other with
tools->options->openoffice.org->java and select the "Free Software Foundation"
option instead of the auto-selected "Sun Microsystems" option. And then restart
OOo and try the wizards again

Comment 4 Caolan McNamara 2008-07-01 13:12:11 UTC
Created attachment 310663 [details]
mapped stack

Comment 5 Caolan McNamara 2008-07-01 13:17:13 UTC
report_should_not_reach_here(char const*, int) ... os_abort inside openjdk

Not sure if this is openjdk specific, but I'm fairly sure that it worked under
libgcj the last time I was able to check under ppc. #3 shows how to try with
libgcj to see if that theory is correct

Comment 6 Ian Chapman 2008-07-01 14:35:19 UTC
(In reply to comment #3)
> I wonder if this also happens if you use libgcj ? 

Yes unfortunately it does. Well the behaviour is slightly different. Instead of
an absolute crash, OO locks solid and CPU usage hangs around %100 indefinately
in some kind of infinite loop.

This is with: libgcj-4.3.0-8.ppc

If there's any way I can get useful debugging information from this, let me know.

Comment 7 Ian Chapman 2008-07-02 02:08:07 UTC
Out of curiosity I've just tried IBM's java implementation for PPC:

ibm-java-ppc-sdk-6.0-1.0.ppc.rpm (Java 1.6.0)

and surprisingly this works perfectly. Obviously not an official solution however.

Comment 8 Lillian Angel 2008-11-05 18:19:56 UTC
Can you try to reproduce this with the latest version of OpenJDK in rawhide?

Comment 9 Gary Benson 2008-11-06 08:34:31 UTC
This was probably http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=184.
It should be fixed now, at least upstream.


Note You need to log in before you can comment on or make changes to this bug.