Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453477 - duplicated entries in CSV download for some fields
Summary: duplicated entries in CSV download for some fields
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: John Matthews
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space02
TreeView+ depends on / blocked
 
Reported: 2008-06-30 21:06 UTC by John Matthews
Modified: 2009-09-17 06:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 06:59:26 UTC


Attachments (Terms of Use)

Description John Matthews 2008-06-30 21:06:42 UTC
To reproduce:

1. go to system list, 
2. click "download csv"
3. all entitlements are duplicated for systems that were displayed on the list.

This is because those entries are being elaborated twice

Comment 1 John Matthews 2008-06-30 21:16:57 UTC
Fixed in commit a0200a462868a25ea36790c7dd6725b8c047ac6c

Issue was that when elaborating with a "List" as a field, the data was being
added without checking to see if it was already present.  



Comment 2 Brandon Perkins 2008-09-04 02:54:33 UTC
More details in  Bug 445895   -  duplicated entries in CSV download for some fields.

Comment 3 Devan Goodwin 2008-09-05 14:25:57 UTC
Looks good in spacewalk 0.2.

Comment 4 Miroslav Suchý 2009-09-17 06:59:26 UTC
Spacewalk is released for long time.


Note You need to log in before you can comment on or make changes to this bug.