Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453460 - /etc/sysconfig/cpuspeed settings aren't reflected after bootup
Summary: /etc/sysconfig/cpuspeed settings aren't reflected after bootup
Keywords:
Status: CLOSED DUPLICATE of bug 447975
Alias: None
Product: Fedora
Classification: Fedora
Component: cpuspeed
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 18:59 UTC by David Rees
Modified: 2008-06-30 19:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 19:40:03 UTC


Attachments (Terms of Use)

Description David Rees 2008-06-30 18:59:48 UTC
Description of problem:
The settings specified in /etc/sysconfig/cpuspeed aren't reflected by the
ondemand governor after boot up.

Version-Release number of selected component (if applicable):
cpuspeed-1.2.1-5.fc9.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Boot up a system which supports kernel based CPU frequency changing.
2. Check the value of
/sys/devices/system/cpu/cpu0/cpufreq/ondemand/ignore_nice_load. If it matches
IGNORE_NICE in /etc/sysconfig/cpuspeed, change it and reboot. It will not match
after the change, if it was not already mismatched (it is mismatched by default
on AMD systems I've tested).
  
Actual results:
If IGNORE_NICE is set to 0,
/sys/devices/system/cpu/cpu0/cpufreq/ondemand/ignore_nice_load is set to 1 after
boot.

Expected results:
If IGNORE_NICE is set to 0,
/sys/devices/system/cpu/cpu0/cpufreq/ondemand/ignore_nice_load is set to 0 after
boot.


Additional info:
I suspect that either the cpufreq modules are getting loaded before cpuspeed is
started, or the governor is getting reloaded after cpuspeed is started. If you
restart cpuspeed the correct settings are set.

Comment 1 Jarod Wilson 2008-06-30 19:27:13 UTC
There's a dupe bug around here somewhere... Its actually gnome's cpufreq applet
that stomps on that setting. We do the right thing, then when gnome starts up,
it bludgeons everything. :\

Comment 2 David Rees 2008-06-30 19:39:10 UTC
Hmm, I think you're right. I found a system which supports cpufreq but boots in
to run level 3 and it seems to be OK.

Comment 3 Dave Jones 2008-06-30 19:40:03 UTC

*** This bug has been marked as a duplicate of 447975 ***


Note You need to log in before you can comment on or make changes to this bug.