Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453452 - autofs & nautilus don't play well together
Summary: autofs & nautilus don't play well together
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nautilus
Version: 4.7
Hardware: s390x
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Tomáš Bžatek
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 18:35 UTC by Suzanne Hillman
Modified: 2015-03-03 22:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 18:58:14 UTC


Attachments (Terms of Use)

Description Suzanne Hillman 2008-06-30 18:35:07 UTC
Description of problem:
Mounting a NFS point via autofs (eg /net/bigpapi.bos.redhat.com), creating a
link into it, and then sitting with the link open results in the folders within
that linked folders no longer accessable. An attempted access should re-mount it.


Version-Release number of selected component (if applicable):
2.8.1-6.EL4

How reproducible:
Always, it seems.

Steps to Reproduce:
1. Get an s390x machine with re20080611's tree (snap 3, I think)
2. ls /net/bigpapi.bos.redhat.com
3. ln -s /net/bigpapi.bos.redhat.com/vol/engineering/ Desktop/nfs_test
4. With nautilus, open Desktop/nfs_test, verify that you can actually open one
of the subdirectories now. Wait a couple minutes. Try again to open a subdirectory.
  
Actual results:
Fail to have it open, and it says maybe it was deleted.

Expected results:
nautilus should tell autofs that it's trying to access it, which should remount
it if the mount timed out. It should be possible to open the folders in that
directory.

Additional info:

This is very definitely not a regression, as it seemed even worse when I
downgraded to 4.6's nautilus. There, I was unable to open the link at _all_,
because it would immediately have the linked mount point go away from under it.

Comment 1 Suzanne Hillman 2008-06-30 18:58:14 UTC
Ah, no. I am mistaken, sorry. Closing.


Note You need to log in before you can comment on or make changes to this bug.