Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453436 - Sound does not work, audiotestsrc, ConsoleKit does not recognize me
Summary: Sound does not work, audiotestsrc, ConsoleKit does not recognize me
Keywords:
Status: CLOSED DUPLICATE of bug 462160
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 16:41 UTC by Stepan Kasal
Modified: 2015-01-14 23:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-16 17:02:20 UTC


Attachments (Terms of Use)

Description Stepan Kasal 2008-06-30 16:41:17 UTC
The sound stopped playing, both from console and from X Window.

Sound Preferences, started from System|Preferences|Hardware|Sound from the main
menu. If I click Test, I get a message box with:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink:
Internal GStreamer error: state change failed.  Please file a bug at
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer

I also tried to run ConsoleKit in a terminal window and got:

$ ck-list-sessions 
Session1:
	uid = '0'
	realname = 'root'
	seat = 'Seat1'
	session-type = ''
	active = FALSE
	x11-display = ''
	x11-display-device = ''
	display-device = '/dev/tty1'
	remote-host-name = ''
	is-local = TRUE
	on-since = '2008-06-30T10:56:35Z'
	idle-since-hint = '2008-06-30T16:18:45Z'

This is wrong, I'm logged in as kasal, and X window was started by "startx".

My system is a mix of F-9 and rawhide rpms.

If this report can help to fix something, I'd be happy to help with debugging
according to your hints.

Comment 1 David Zeuthen 2008-06-30 17:10:55 UTC
Looks like a ConsoleKit bug to me. Then again if you're running a mixture of F9
and Rawhide rpm's maybe that's why.

Comment 2 Edouard Bourguignon 2008-09-15 21:55:47 UTC
I have same problem on a clean rawhide Fedora alpha1. No sound, no hibernate, and no shutdown/restart is allowed from user session. This is not so low severity. It was working few days ago.

Comment 3 Matthias Clasen 2008-09-16 03:07:48 UTC
Most likely a duplicate of bug 462160

Comment 4 Edouard Bourguignon 2008-09-16 16:19:13 UTC
yes for me gdm-2.23.92-4.fc10 has fixed this bug too.

Comment 5 Matthias Clasen 2008-09-16 17:02:20 UTC

*** This bug has been marked as a duplicate of bug 462160 ***


Note You need to log in before you can comment on or make changes to this bug.