Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453434 - Node names all show up as M in system-config-cluster in cluster management tab
Summary: Node names all show up as M in system-config-cluster in cluster management tab
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
: 460978 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 16:22 UTC by Shane Bradley
Modified: 2018-10-27 14:38 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-14 18:17:54 UTC


Attachments (Terms of Use)
patch to fix issue where "m" was displayed instead of node name (deleted)
2008-06-30 16:25 UTC, Shane Bradley
no flags Details | Diff

Description Shane Bradley 2008-06-30 16:22:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
Cluster "member" name column shows "M" for all the nodes(system-config-cluster utility, when clicked on "Cluster Management" tab) in place of member name.

This appears to be only an issue with RHEL4 and not with RHEL5. Most likely because the cman_tool nodes output is different on each version.

Version-Release number of selected component (if applicable):
system-config-cluster-1.0.51-2.0.el4_6.2

How reproducible:
Always


Steps to Reproduce:
1. create a cluster so that cman_tool nodes displays M for all memebers
2. system-config-cluster
3. click on management tab

Actual Results:
Cluster "member" name column shows "M" for all the nodes(system-config-cluster utility, when clicked on "Cluster Management" tab) in place of member name.

Expected Results:
Management tab should show cluster name under name field instead of "m".

Additional info:

Comment 1 Shane Bradley 2008-06-30 16:25:08 UTC
Created attachment 310596 [details]
patch to fix issue where "m" was displayed instead of node name

Built on src.rpm: system-config-cluster-1.0.51-2.0.el4_6.2.src.rpm

Comment 2 Shane Bradley 2008-06-30 16:25:58 UTC
I have tested and verified patch fixes issue with RHEL4.

Comment 3 Jim Parsons 2008-06-30 19:22:38 UTC
Yikes...thanks so much Shane. 

Comment 4 Mark Huth 2008-09-27 04:18:44 UTC
*** Bug 460978 has been marked as a duplicate of this bug. ***

Comment 6 Jim Parsons 2008-10-02 17:34:38 UTC
In this deep today - almost set.

Comment 8 Kiersten (Kerri) Anderson 2008-10-22 19:15:51 UTC
Jim, we need a brew build of this fix in order to release a hotfix for the
customer.

Comment 10 RHEL Product and Program Management 2008-10-22 20:17:39 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being marked as a blocker for this release.  

Please resolve ASAP.

Comment 20 Chris Feist 2009-07-29 17:07:45 UTC
Pulling the 4.8.z flag as this won't be fixed until 4.9 at the earliest.


Note You need to log in before you can comment on or make changes to this bug.