Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453421 - Evolution fails to start on x86_64
Summary: Evolution fails to start on x86_64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 15:02 UTC by Paul F. Johnson
Modified: 2008-07-09 08:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-09 08:55:43 UTC


Attachments (Terms of Use)
Output from valgrind (deleted)
2008-07-01 10:32 UTC, Paul F. Johnson
no flags Details

Description Paul F. Johnson 2008-06-30 15:02:57 UTC
Description of problem:
Evolution is unable to start due to a glibc problem

Version-Release number of selected component (if applicable):
glibc 2.8.90-7
glib 1.2.10-29

How reproducible:
Always

Steps to Reproduce:
1. start evolution from either the command line or desktop icon
2.
3.
  
Actual results:
with thread apply all bt using gdb enabled
throwback gives
[Thread debugging using libthread_db enabled]
[New Thread 0x7ffff7f9e7a0 (LWP 8146)]
CalDAV Eplugin starting up ...
** (evolution:8146): DEBUG: mailto URL command: evolution %s
** (evolution:8146): DEBUG: mailto URL program: evolution

GLib-ERROR **: gmem.c:136: failed to allocate 31740376080 bytes
aborting...

Program received signal SIGTRAP, Trace/breakpoint trap
IA__g_logv (log domain=<value optimized out>, log_level=<value optimized out>,
format=<value optimized out>, args1=<value optimized out>) at gmessages.c:503
503  g_private_set(g_log_depth, GUINT_TO_POINTER(depth));

Expected results:
Evolution should start

Additional info:
Untested on x86

Comment 1 Rex Dieter 2008-06-30 15:09:38 UTC
You probably meant glib2 here.

Comment 2 Paul F. Johnson 2008-07-01 10:32:53 UTC
Created attachment 310649 [details]
Output from valgrind

Comment 3 Milan Crha 2008-07-01 10:57:35 UTC
It can be also because of broken summary file in one of your local folders. The
place where it crashed is in time of creating the folder structure and loading
message from the summary. If you try to recreate index/summary files from your
~/.evolution/mail/local directory, (and subdirectories), then there's some
chance to get this fixed. More info how to recreate summary/index files can be
found here:
http://www.go-evolution.org/FAQ#Why_do_I_get_an_error_.22Summary_and_folder_mismatch.2C_even_after_a_sync.22.3F

Please do backup of the 'local' folder before doing anything, to be able to
return to some data when something goes wrong.

Also, the above link describes the error on an Inbox folder, but it can be in
any folder you have, from the valgrind output is not obvious which folder is in
question.

Comment 4 Matthias Clasen 2008-07-08 15:04:26 UTC
I don't think this is a glib problem, really. 

Moving back to evolution.

Comment 5 Matthew Barnes 2008-07-08 15:25:26 UTC
I don't think it's a glibc problem either.  Looks like another 64-bit
miscalculation in libcamel.  We've seen this before with libcamel.

Paul, can you get a backtrace for this?

Comment 6 Paul F. Johnson 2008-07-08 17:59:46 UTC
I've done as in comment #3 which seems to have sorted the problem, however,
there is already a valgrind output attached to this bug, though I suspect you
need a libcamel one...

Comment 7 Matthew Barnes 2008-07-08 19:46:52 UTC
Okay, so are you still unable to start then or can the bug be closed?

Comment 8 Paul F. Johnson 2008-07-09 08:55:43 UTC
I'll close it.


Note You need to log in before you can comment on or make changes to this bug.