Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453409 - man page alteration for suspend command
Summary: man page alteration for suspend command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bash
Version: 5.2
Hardware: All
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Roman Rakus
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 13:30 UTC by Adam Stokes
Modified: 2018-10-20 02:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:10:23 UTC


Attachments (Terms of Use)
man page update (deleted)
2008-06-30 13:30 UTC, Adam Stokes
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0116 normal SHIPPED_LIVE bash bug fix update 2009-01-20 16:04:47 UTC

Description Adam Stokes 2008-06-30 13:30:39 UTC
Description of Problem:
We tested suspend command.

There is a comment in the manpage of suspend.
suspend [-f]
   The -f option says not to complain if this is a login shell; just suspend
   anyway.

Please see the Japanese_suspend_man.txt in the additional info for JPN man.
The contents in this man page can be understood like "suspend command" works in
any case.
However, when user executes suspend command on login shell during remote
connecting, the error messages is output.

[error message]
# suspend
-bash: suspend: cannot suspend a login shell

The result is different from man page's description.

We hope that manpage of suspend is fixed, because we think man page should be
modified to get higher quality.

We will suggest to correct man page as follows:

[draft manpage of suspend]
The suspend command can not suspend the login shell.
However, when -f option is specified, suspend command can suspend even login shell.


Version-Release number of selected component:

Red Hat Enterprise Linux Server release 5.1 (Tikanga)
Architecture: ia64
Kernel Version: kernel-2.6.18-53.el5
bash-3.1-16.1

Drivers or hardware or architecture dependency:
None.

How reproducible:
Always

Step to Reproduce:
Execute suspend command on login shell during remote connecting.

# suspend
-bash: suspend: cannot suspend a login shell


Actual Results:
Description in man page is different from actual operation.

Expected Results:
Description in man page is same with actual operation.

Comment 1 Adam Stokes 2008-06-30 13:30:39 UTC
Created attachment 310582 [details]
man page update

Comment 2 Roman Rakus 2008-07-11 13:06:19 UTC
English version I can easily update, but Japanese version is in man-pages-ja
package. Adding Akira Tagoh to CC, maybe he can update Japanese man page.

Comment 3 Roman Rakus 2008-07-11 13:28:44 UTC
       suspend [-f]
              Suspend  the execution of this shell until it receives a SIGCONT
              signal. The suspend command can not  suspend  the  login  shell.
              However,  when  -f option is specified, suspend command can sus-
              pend even login shell.  The return status is 0 unless the  shell
              is  a  login  shell and -f is not supplied, or if job control is
              not enabled.


Is this English version ok?

Comment 5 RHEL Product and Program Management 2008-07-11 14:01:12 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 11 errata-xmlrpc 2009-01-20 21:10:23 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0116.html


Note You need to log in before you can comment on or make changes to this bug.