Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453373 - samba returns success during posix unlink of symlinks, but doesn't remove the link (RHEL 5 client, RHEL 4 server)
Summary: samba returns success during posix unlink of symlinks, but doesn't remove the...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba
Version: 4.6
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Simo Sorce
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 08:17 UTC by Juanjo Villaplana
Modified: 2008-07-01 13:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-01 13:05:45 UTC


Attachments (Terms of Use)

Description Juanjo Villaplana 2008-06-30 08:17:10 UTC
Description of problem:

This bug seems a duplicate of Bug 383351

Version-Release number of selected component (if applicable):

Client: RHEL 5, kernel-PAE-2.6.18-92.1.6.el5 (cifs 1.50cRH)
Server: RHEL 4, samba-3.0.25b-1.el4_6.5

How reproducible:

Always

Steps to Reproduce: on the client

$ ln -s bar foo
$ rm -f foo ; echo $?
0
$ ls -l foo
lrwxrwxrwx 1 villapla si 3 jun 30 10:14 foo -> bar
  
Actual results:

Symlink is not removed.

Expected results:

Symlink should be removed.

Additional info:

Comment 1 Simo Sorce 2008-06-30 18:49:36 UTC
This problem should be fixed in 4.7 can you try the beta packages and report if
it works for you ?

Comment 2 Juanjo Villaplana 2008-07-01 07:30:24 UTC
samba*-3.0.28-0.el4.5 from RHEL 4.7 beta works fine!

Thanks


Note You need to log in before you can comment on or make changes to this bug.