Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453371 - fence_bladecenter cannot set_power_state
Summary: fence_bladecenter cannot set_power_state
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: fence
Version: 4
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 07:56 UTC by janusz
Modified: 2009-04-16 20:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-01 09:51:08 UTC


Attachments (Terms of Use)

Description janusz 2008-06-30 07:56:16 UTC
Description of problem:

Fenced daemon fails to fence IBM blade center node.

Version-Release number of selected component (if applicable):

fence_bladecenter 1.32.50

How reproducible:

50%.

Steps to Reproduce:
1. Turn off one of machines which is in failover configuration.
2. Wait for messages  "fence "node" failed.
  
Actual results:

Node not fenced, cluster disabled.

Expected results:

Node fenced, cluster ok.

Description:

I want to fence blade in IBM BladeCenter. All goes ok when I want to fence node
1. It goes down, cluster is degraded but serves fine.

But when I want to fence node 3 (blade is in slot 3 and 4). I issue:

fence_bladecenter -a 172.16.3.100 -l properusername -n 3 properpassword -o off 

and get:

unexpected powerstate

If I turn off the 3th blade I got in logs: 
fencing node "nodename"
agent "fence_bladecenter" reports: unexpected powerstate

I have to mention that when I issue:

fence_bladecenter -a 172.16.3.100 -l properusername -n 3 properpassword -o status

I get:

success: blade3 status: On

I can easily operate on node 1, but not 3. I guess 2 issues are possible:
fence_bladecenter's function get_power_state / set_power_state is wrong or the
BladeCenter is malfunctioning.

Thanks,
Janusz.

Comment 1 janusz 2008-07-01 09:51:08 UTC
OK, this is NOT a bug.

fence_bladecenters' function (set_power_state) has no function to recognize
permission errors. In my case the issue was in BladeCenter, which apparently
needed to delete/recreate the authenticating user.


Note You need to log in before you can comment on or make changes to this bug.