Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453363 - Incorrect dependancy required to install
Summary: Incorrect dependancy required to install
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp
Version: 5.2
Hardware: i386
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 05:11 UTC by Mike Gracy
Modified: 2008-07-04 10:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-04 10:14:34 UTC


Attachments (Terms of Use)

Description Mike Gracy 2008-06-30 05:11:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080418 Ubuntu/7.10 (gutsy) Firefox/2.0.0.14

Description of problem:
Incorrect dependency for net-snmp-utils 1:5.3.1-24.el5_2.1
Call for a version not on the satellite server or in any of the channels so that I can sync it into the tree.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.From a machine registered with a satellite server: yum install net-snmp net-snmp-libs net-snmp-utils


Actual Results:
[root@nm4 packages]# yum install net-snmp-utils
Loading "rhnplugin" plugin
Loading "security" plugin
D: login(forceUpdate=False) invoked
D: readCachedLogin invoked
D: Checking pickled loginInfo, currentTime= 1214772349.42 , createTime= 1214770963.35 , expire-offset= 3600.0
D: readCachedLogin(): using pickled loginInfo set to expire at  1214774563.35
mypoints-java-rhel5       100% |=========================| 1.2 kB    00:00     
rhn-tools-rhel-i386-clien 100% |=========================| 1.2 kB    00:00     
rhel-i386-client-suppleme 100% |=========================| 1.2 kB    00:00     
rhel-i386-client-5        100% |=========================| 1.4 kB    00:00     
primary.xml.gz            100% |=========================| 1.3 MB    00:00     
rhel-i386-: ################################################## 3457/3457
dell-om-5x-rhel5          100% |=========================| 1.2 kB    00:00     
rhel-i386-client-workstat 100% |=========================| 1.4 kB    00:00     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package net-snmp-utils.i386 1:5.3.1-24.el5_2.1 set to be updated
--> Processing Dependency: net-snmp = 1:5.3.1-0 for package: net-snmp-utils
--> Finished Dependency Resolution
Error: Missing Dependency: net-snmp = 1:5.3.1-0 is needed by package net-snmp-utils


Expected Results:
It should have installed.

Additional info:

Comment 1 Jan Safranek 2008-07-04 10:14:34 UTC
I can't reproduce this behaviour. I've checked, that
net-snmp-utils-5.3.1-24.el5_2.1.i386.rpm we release has dependency on net-snmp =
1:5.3.1, so net-snmp-5.3.1-24.el5_2.1 would satisfy it. Double check that your
satellite is configured properly and has the right net-snmp rpms.

In future please contact our Red Hat support at redhat.com/support, they should
help you to track this problem and find the guilty component.


Note You need to log in before you can comment on or make changes to this bug.