Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453358 - uninstalled input method is listed
Summary: uninstalled input method is listed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: imsettings
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 03:44 UTC by Jens Petersen
Modified: 2009-03-10 10:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-10 10:39:49 UTC


Attachments (Terms of Use)

Description Jens Petersen 2008-06-30 03:44:43 UTC
Description of problem:
If one selections an input method in im-chooser which creates a .xinputrc symlink
and then removes the package corresponding to that input method,
imsettings and im-chooser still list it even when it is not running or installed
any more.

Steps to Reproduce:
1. yum install gcin
2. selection gcin as input method in im-chooser
3. use gcin
4. yum remove gcin
5. restart desktop session
6. run im-chooser or imsettings-list

Actual results:
6. gcin still shown even though it is not installed

Expected results:
6. only available input methods to be shown

Comment 1 Jens Petersen 2008-06-30 07:35:23 UTC
Actually I might be the gconf.conf.rpmsave file?

(Not sure if it is a good idea to have xinput config files considered %config
though.)

Comment 2 Jens Petersen 2008-07-01 04:33:16 UTC
(In reply to comment #1)
> Actually [it] might be the gconf.conf.rpmsave file?

Now I realised that this file came about of course because I edited gcin.conf before
uninstalling (while testing another issue).

Comment 3 Akira TAGOH 2008-07-02 12:04:58 UTC
Actually I found two issues in imsettings. one is a regression. in the past the
target config file was everything in /etc/X11/xinit/xinput.d. which is correctly
something that has the suffix of .conf.
another one is, old cache that .xinputrc is referring to is still existing.

First issue has been fixed in SVN. hopefully next one will be fixed shortly.
just FYI

Comment 4 Akira TAGOH 2008-07-03 11:19:33 UTC
Fixed in 0.101.3-1.fc10.

Comment 5 Tony Fu 2008-09-10 03:18:23 UTC
requested by Jens Petersen (#27995)

Comment 6 Bug Zapper 2008-11-26 02:29:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.