Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453351 - Ethernet configured for static IP but is being configured with DHCP
Summary: Ethernet configured for static IP but is being configured with DHCP
Keywords:
Status: CLOSED DUPLICATE of bug 134886
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-30 01:38 UTC by David Gesswein
Modified: 2008-07-02 23:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-02 23:00:39 UTC


Attachments (Terms of Use)
Network initialization from /var/log/messages (deleted)
2008-06-30 01:39 UTC, David Gesswein
no flags Details

Description David Gesswein 2008-06-30 01:38:37 UTC
Description of problem:
I have configured the Ethernet adapter to static IP through
system->administration->network but the system still configures the adapter
using DHCP. Not sure what component the bug report should be against. 

Version-Release number of selected component (if applicable):
system-config-network-1.5.10-1.fc9.noarch

How reproducible:
I just installed FC9 then found it was setup for DHCP and changed it to static
using the GUI.  All components are updated to current as of today.


Additional info:

In system-config-network the GUI check box controlled by NetworkManager is not
selected but from /var/log/messages appears that it is being controlled by
network manager.

/etc/sysconfig/network-scripts/ifcfg-eth0

# Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller
DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.2.255
HWADDR=00:11:2f:e0:36:4b
IPADDR=192.168.2.12
NETMASK=255.255.255.0
NETWORK=192.168.2.0
ONBOOT=yes
DNS1=192.168.2.3
NM_CONTROLLED=

Comment 1 David Gesswein 2008-06-30 01:39:52 UTC
Created attachment 310549 [details]
Network initialization from /var/log/messages

Comment 2 David Gesswein 2008-06-30 02:14:12 UTC
I got it to stop configuring with network manager by checking the controlled by
NetworkManager box, exiting then unchecking it. Now even though I have activate
device when computer starts it does not activate the device.  If I manually
activate it I do get the static IP address. I tried checking and unchecking the
activate at boot but it has no effect.

Boot lines from /var/log/messages
Jun 29 22:04:46 hugin2 nm-system-settings:    ifcfg-fedora: parsing
/etc/sysconfig/network-scripts/ifcfg-lo ...
Jun 29 22:04:46 hugin2 nm-system-settings:    ifcfg-fedora:     error: Ignoring
loopback device config.
Jun 29 22:04:46 hugin2 nm-system-settings:    ifcfg-fedora: parsing
/etc/sysconfig/network-scripts/ifcfg-eth0 ...
Jun 29 22:04:46 hugin2 nm-system-settings:    ifcfg-fedora:     read connection
'System eth0'
Jun 29 22:04:46 hugin2 nm-system-settings:    ifcfg-fedora: Ignoring connection
'System eth0' and its device because NM_CONTROLLED was false.
Jun 29 22:04:46 hugin2 NetworkManager: <info>  (eth0): now unmanaged


Comment 3 David Gesswein 2008-06-30 02:34:49 UTC
Found the next piece of the puzzle.  Under system->administration->services it
said that network was running but disabled.  When I set it to enabled then eth0
properly configures static IP on boot.

Now I have the issue where firefox always starts in offline mode even though the
network is functional.


Comment 4 Dan Williams 2008-07-02 23:00:39 UTC
Updates in f9-updates would likely have fixed your issue without having to
revert to the 'network' service.  If you'd like to debug the issue with
NetworkManager further we can do that, but if you want to stick with the
'network' service for now (since that's working for you) that's OK too.

*** This bug has been marked as a duplicate of 134886 ***


Note You need to log in before you can comment on or make changes to this bug.