Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453341 - RFE: tilda should get focus on activation
Summary: RFE: tilda should get focus on activation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tilda
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Xavier Lamien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-29 22:12 UTC by Stefan Jensen
Modified: 2008-07-24 11:22 UTC (History)
1 user (show)

Fixed In Version: 0.9.6-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 06:22:52 UTC


Attachments (Terms of Use)

Description Stefan Jensen 2008-06-29 22:12:44 UTC
Description of problem:

When i use the configured shortcut to show up tilda, i have to move the mouse to
the tilda window an click it first to start typing.

My suggestion is, that tilda gets the focus on activation (using the shortcut).
This would it more usefully, i think.

Version-Release number of selected component (if applicable):

tilda-0.9.5-1.fc8

How reproducible:

Always

Steps to Reproduce:
1. start tilda
2. use shortcut, while another window has the focus
3. try typing
  
Actual results:

tilda does not get the focus and the typing is showed up in the window with the
current focus.

Expected results:

tilda gets the focus on activation and the typing is showed up in the tilda window.

Additional info:

None

Comment 1 Xavier Lamien 2008-07-04 13:11:50 UTC
hm...i'm afraid that it works well on mine.
So, i'm currently unable to reproduce your error :(

did you have the same trouble on previous release ?


Comment 2 Stefan Jensen 2008-07-04 16:55:32 UTC
I just checked out, that it works (tilda gets the focus) when i initially start
tilda and using the shortcut for the first time. Next time when i use the
shortcut again, it doesn't work and tilda get not the focus. When i restart
tilda, it works again only one time.

I check later today, if an older version behaves this way too.

thx

Comment 3 Stefan Jensen 2008-07-08 19:35:55 UTC
ok, i tried the older version (tilda-0.9.5-1.fc8). It behaves as above, too.

It seems to conflicts with compiz, if i disable compiz it works like expected.

So maybe move this to a compiz bug?

best regards

Comment 4 Xavier Lamien 2008-07-23 12:42:53 UTC
well,

could you try with this release update : tilda-0.9.6-1.fc9
will be pushed to testing soonish.

It shipped with a bug fix on focus trouble with metacity-2.22.

also available here : http://koji.fedoraproject.org/koji/taskinfo?taskID=733799

Comment 5 Stefan Jensen 2008-07-24 00:14:32 UTC
Tried it and it seems to work very well. Thank you very much!

Comment 6 Xavier Lamien 2008-07-24 06:22:52 UTC
excellent !

Add a comment about on bodhi if you don't mind, thx.



Comment 7 Stefan Jensen 2008-07-24 11:22:14 UTC
Done. :-) Don't forget a F8 version, please. Thanks.


Note You need to log in before you can comment on or make changes to this bug.