Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453340 - caching-nameserver update breaks customized config
Summary: caching-nameserver update breaks customized config
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: caching-nameserver
Version: 4.6
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 562748 562750
TreeView+ depends on / blocked
 
Reported: 2008-06-29 22:10 UTC by Milan Kerslager
Modified: 2018-11-14 18:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-14 20:38:56 UTC


Attachments (Terms of Use)

Description Milan Kerslager 2008-06-29 22:10:03 UTC
I'm using bind-chroot and I have customized named.conf so I had:
symlink /etc/named.conf -> /var/named/chroot/etc/named.conf

Latest caching-nameserver renamed my named.conf to named.conf.rpmsave in
/var/named/chroot/etc and thus breaks my configuration.

The reason is that new package has the same named.conf (aka MD5SUM) but with
different dates (last-modified). This is wrong as this breaks all working
configs around the world in all RHEL4 installations.

The source RPM has named.conf as source file. This is good. But the file is
placed to its destination by command "install" without "--preserve-timestamps"
option (-p). And this is the bug we hit now.

I think that all yours src.rpm packages should be checked to use "-p" on config
files or you will be blamed again and again. So new policy for updated packes
should be created and all updated packages in the future should be fixed before
shipping.

And RHEL6 should not have this bug in all packages or it will break upgrades.

Comment 1 Ryoichiro Tsuruno 2008-07-02 08:51:54 UTC
We at Red Hat Japan received the same report from our customers.  This package
forced them to move .rpmsave file back  in order to get their bind working again.

We are aware that caching-nameserver replace named.conf by design and reported
the their usage is not typical (or recommended), however, in order to be on the
safe side, we think it should be set to "noreplace".

Comment 2 Boris Folgmann 2008-07-02 13:42:25 UTC
Are you sure what happened with your files Milan? I updated to
caching-nameserver.noarch 0:7.3-3.0.1.el4_6 but observed a different, even more
severe problem with rpm:

My /var/named/chroot/etc/named.conf was customized, which means that it
contained data that was very important for me. The update kept only the "old
version" symlink at /etc/named.conf as /etc/named.conf.rpmsave but overwrote the
original file at /var/named/chroot/etc/named.conf with the new version in the rpm!

So my own data was lost. I had to recover it from a backup.
RPM should instead keep a copy of my own /var/named/chroot/etc/named.conf as
/var/named/chroot/etc/named.conf.rpmsave.


Comment 3 Adam Tkac 2008-07-03 08:50:51 UTC
Main problem is that caching-nameserver package is not designed for servers, it
is configuration for local caching only nameserver. Configuration files are
overwritten since good old RHEL3 GA so it's nothing new.

Although caching-nameserver package should not be installed on authoritative
servers I think we will avoid such problems in future. In next update named.conf
will be marked as noreplace

Comment 4 Boris Folgmann 2008-07-14 12:30:18 UTC
Are you sure Adam? It's the easiest way to get the named.ca file that you need
to run a nameserver.

Comment 5 Milan Kerslager 2008-07-15 07:56:42 UTC
T thing so too. Every namesever have to have root zone definition, loopback etc
(by RFC request). I see no reason to not use what is is provided by this package
because every generic file could be upgraded (root zone) or fixed in case of a
bug (others).

Your system-config-nameserver should use these files too to be able to be
updated without running updated system-config-nameserver.


Note You need to log in before you can comment on or make changes to this bug.