Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453324 - PackageKit -- can't review updates
Summary: PackageKit -- can't review updates
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-29 18:01 UTC by Steven Whetzel
Modified: 2008-10-16 01:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-16 01:35:23 UTC


Attachments (Terms of Use)

Description Steven Whetzel 2008-06-29 18:01:34 UTC
PackageKit gives error messages when reviewing updates





Steps to Reproduce:
1.  Wait for an available update
2.  Click PackageKit Icon and choose Show updates
3.  Click Review button

all messages are similar, here's an example:

http://img521.imageshack.us/my.php?image=pkij9.png

Comment 1 Richard Hughes 2008-06-30 07:15:06 UTC
Can you try:

yum update yum PackageKit gnome-packagekit

and then try again please. Thanks.

Comment 2 Steven Whetzel 2008-07-01 02:22:00 UTC
Done.  Result -- No Packages marked for Update

Comment 3 Richard Hughes 2008-07-04 10:04:17 UTC
Right, this is coming from inside of yum, I'll re-assign. Out of interest, whats
the output of "rpm -qa | grep yum"? Thanks.

Comment 4 Jan Hutař 2008-07-08 08:28:20 UTC
Maybe this one is another duplicate of bug 447347?

Could you please provide output of:

  $ rpm -qa | grep -e yum -ie PackageKit

I have these versions and "Review" of a recent squid advisory works as expected.

yum-3.2.16-4.fc9.noarch
PackageKit-0.1.12-13.20080522.fc9.x86_64
gnome-packagekit-0.1.12-14.20080516.fc9.x86_64

Comment 5 Steven Whetzel 2008-07-31 02:52:45 UTC
Package Kit was updated today.  So I'll have to wait to see if this keeps happening:

$ rpm -qa | grep yum
yum-utils-1.1.14-4.fc9.noarch
yum-metadata-parser-1.1.2-8.fc9.i386
yum-3.2.17-2.fc9.noarch
yum-packagekit-0.2.3-6.fc9.i386

$ rpm -qa | grep -e yum -ie PackageKit
gnome-packagekit-0.2.3-7.fc9.i386
yum-utils-1.1.14-4.fc9.noarch
yum-metadata-parser-1.1.2-8.fc9.i386
PackageKit-libs-0.2.3-6.fc9.i386
yum-3.2.17-2.fc9.noarch
PackageKit-0.2.3-6.fc9.i386
yum-packagekit-0.2.3-6.fc9.i386

Sorry I took so long to reply. 

Comment 6 Steven Whetzel 2008-08-01 02:42:41 UTC
Sure enough: 8 updates pending

A problem that we were not expecting has occurred.  Please report this bug at
https://bugs.freedesktop.org/ with the error description.

Error Type: <type 'exceptions.AttributeError'>
Error Value: Updates instance has no attribute 'obsoletes'
  File : /usr/share/PackageKit/helpers/yum/get-update-detail.py , line 17, in
<module>
    backend.get_update_detail(package)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1491, in
get_update_detail
    obsolete = self._get_obsoleted(pkg.name)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1401, in
_get_obsoleted
    obsoletes = self.yumbase.up.getObsoletesTuples(newest=1)
  File : /usr/lib/python2.5/site-packages/rpmUtils/updates.py , line 568, in
getObsoletesTuples
    obslist = self.obsoletes.keys()


Comment 7 James Antill 2008-08-07 19:57:23 UTC
 I'm reassigning this back to packagekit unless someone can reproduce with the yum cmd line.

Comment 8 Richard Hughes 2008-08-18 08:56:58 UTC
James -- PackageKit is just using the yum API -- I guess the cli isn't using this part of the API, but it still should work. I don't think reassigning to the application that uses the library is the right thing to do when the library goes pop.

Comment 9 Steven Whetzel 2008-08-18 15:41:11 UTC
I'm not sure exactly what was wrong.  I switched to Fedora Core 8 for a while and later reinstalled 9.  This problem did not occur then.  The only thing that I did differently was removing gcj and mono.  Could the problem that I described have been related to that or simply a fluke?  I have since started using Kubuntu so, I won't be able to offer any more feedback.

Comment 10 James Antill 2008-08-18 19:48:12 UTC
 Richard, if it's a bug in yum I'll be happy to fix it. But the above doesn't look like such.

 From __init__.py:

    up = property(fget=lambda self: self._getUpdates(),

...which then calls:

_up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())

...and rpmUtils.updates.Updates has a getObsoletesTuples() (and the yum cmd line uses it, so it does work).

 I can only assume PK has done something weird/different that breaks part of the above.

 If you are stuck I'd be happy to help, if there's some kind of reproducer or way to get data ... but atm. it's at least as likely to be PK as yum, from what I can see.

Comment 11 Richard Hughes 2008-10-09 16:39:33 UTC
Steven, does this still happen with the latest PackageKit and yum packages installed?

Comment 12 Steven Whetzel 2008-10-16 01:35:23 UTC
Hey all.  Closing this bug.  I've switched to Kubuntu.  This did not happen when I reinstalled Fedora 9.  Thanks for all the interest.


Note You need to log in before you can comment on or make changes to this bug.