Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453313 - Copy of the files and Folders does not work
Summary: Copy of the files and Folders does not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fwbackups
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Stewart Adam
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-29 15:18 UTC by Bill Komanetsky
Modified: 2009-01-14 18:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-14 18:36:10 UTC


Attachments (Terms of Use)

Description Bill Komanetsky 2008-06-29 15:18:23 UTC
I love fwbackups, but the current rc2 version does not execute 'Copy of the
files and folders' and fails.  (Below is the debug log).

I am wanting to copy a path /media/Backups to a destination named
/media/USB_Backups1/Backups.  I just want to do a straight copy of the files
which are backup archive files created by fwbackups.  It is to a USB connected
drive for archival purposes.  Times is set to all months, all days of week at
2:00 am.  Options are Enabled, Backup is recursive, Printe installed packages to
a text file, Number of old backups to keep = 1 and Copy of thye files and
folders is selected.  The folder on the destination drive is created, but it
looks like fwbackups is trying to backup to a directory that does not exist (via
the log).

I am able to fix this problem by removing any spaces in the backup set's name
(example:  I changed "Backup Replica" to "BackupReplica" and it worked.

Not sure if you want to change this or not let spaces in the backup set's name.

Thanks for a great tool!


----------------------
Jun 29 07:46:01 :: DEBUG : Created destination folder
`/media/USB_Backups1/Backups/Backup-Backup Replica-2008-06-29'
Jun 29 07:46:01 :: DEBUG : Running command: nice -n 0 rsync -g -o -p -t -R -r
--exclude=.* -l '/media/Backups' /media/USB_Backups1/Backups/Backup-Backup
Replica-2008-06-29
Jun 29 07:46:01 :: DEBUG : Starting subprocess with PID 5137
Jun 29 08:05:04 :: DEBUG : Subprocess with PID 5137 exited with status 23
Jun 29 08:05:04 :: ERROR : Error(s) occurred while backing up path
''/media/Backups''.
Please check the error output below to determine if any files are incomplete or
missing.
Jun 29 08:05:04 :: ERROR : Output:
Return value: 23
stdout: 
stderr: rsync: link_stat "/media/USB_Backups1/Backups/Backup-Backup" failed: No
such file or directory (2)
rsync error: some files could not be transferred (code 23) at main.c(1031)
[sender=3.0.2]

Jun 29 08:05:14 :: INFO : Finished automatic backup operation of set 'Backup
Replica'
Jun 29 08:05:14 :: DEBUG : Thread returned with retval False

Comment 1 Stewart Adam 2008-06-30 04:46:49 UTC
If you run this command as root:
# nice -n 0 rsync -g -o -p -t -R -r --exclude=.* -l '/media/Backups' \
  '/media/USB_Backups1/Backups/Backup-Backup Replica-2008-06-29 --progress

as root, does it copy correctly? If so, then this will be a easy fix (missing
quotes)

Comment 2 Stewart Adam 2008-11-29 03:33:05 UTC
This should have been fixed a while back when I released rc3, the final 1.43.2 is now in the repositories. Can you confirm the problem is resolved?

Comment 3 Stewart Adam 2009-01-14 18:36:10 UTC
This is working for me with 1.43.2 final, so I'll close this. Please feel free to reopen if you can still reproduce the bug.


Note You need to log in before you can comment on or make changes to this bug.