Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453310 - tcl.x86_64 pulls in i386 packages
Summary: tcl.x86_64 pulls in i386 packages
Keywords:
Status: CLOSED DUPLICATE of bug 453302
Alias: None
Product: Fedora
Classification: Fedora
Component: tcl
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-29 14:59 UTC by Allan Engelhardt
Modified: 2008-06-30 08:15 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 08:15:22 UTC


Attachments (Terms of Use)

Description Allan Engelhardt 2008-06-29 14:59:53 UTC
Description of problem:

Attempting to upgrade tcl.x86_64 to version 1:8.5.2-2.fc9 on a 64-bit only
system pulls in tcl.i386 and glibc.i386 

Version-Release number of selected component (if applicable): 1:8.5.2-2.fc9


How reproducible: Always


Steps to Reproduce:
1. yum update tcl.x86_64 tcl-devel.x86_64
[...cut...]
--> Running transaction check
--> Processing Dependency: tcl-devel = 1:8.5.1 for package: tk-devel
---> Package tcl-devel.x86_64 1:8.5.2-2.fc9 set to be updated
---> Package tcl.x86_64 1:8.5.2-2.fc9 set to be updated
--> Processing Dependency: tcl = 1:8.5.1 for package: tk
--> Processing Dependency: tcl = 1:8.5.1-4.fc9 for package: tcl-devel
--> Running transaction check
---> Package tcl.i386 1:8.5.1-4.fc9 set to be updated
--> Processing Dependency: libc.so.6(GLIBC_2.2) for package: tcl
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: tcl
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: tcl
--> Processing Dependency: libc.so.6 for package: tcl
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: tcl
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: tcl
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: tcl
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: tcl
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: tcl
--> Processing Dependency: libdl.so.2 for package: tcl
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: tcl
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: tcl
--> Processing Dependency: libm.so.6 for package: tcl
---> Package tcl-devel.i386 1:8.5.1-4.fc9 set to be updated
--> Running transaction check
---> Package glibc.i386 0:2.8-3 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 tcl                     x86_64     1:8.5.2-2.fc9    updates           2.2 M
 tcl-devel               x86_64     1:8.5.2-2.fc9    updates           171 k
Installing for dependencies:
 glibc                   i386       2.8-3            fedora            4.6 M
 tcl                     i386       1:8.5.1-4.fc9    fedora            2.2 M
 tcl-devel               i386       1:8.5.1-4.fc9    fedora            171 k

Transaction Summary
=============================================================================
Install      3 Package(s)         
Update       2 Package(s)         
Remove       0 Package(s)         

Total download size: 9.3 M
Is this ok [y/N]: N
Exiting on user Command
Complete!

  
Actual results: As above


Expected results: Only use the x86_64 packages.


Additional info: This appears to be different from the issue with the Tk package
reported as Bug 453239 (there is no Tk dependency here)

Comment 1 Marcela Mašláňová 2008-06-30 08:15:22 UTC

*** This bug has been marked as a duplicate of 453302 ***


Note You need to log in before you can comment on or make changes to this bug.