Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453300 - GVFSD-GPhoto2 segfaults on connecting Canon PowerShot Camera
Summary: GVFSD-GPhoto2 segfaults on connecting Canon PowerShot Camera
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gphoto2
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-29 09:13 UTC by Gerard Fernandes
Modified: 2013-07-02 23:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-23 09:52:53 UTC


Attachments (Terms of Use)
error message (deleted)
2008-06-29 09:13 UTC, Gerard Fernandes
no flags Details

Description Gerard Fernandes 2008-06-29 09:13:43 UTC
Description of problem: On connecting a Canon Powershot A700, get a DBUS timeout
error saying it's unable to mount the camera. Looking in the logs, I see:

Jun 29 10:03:30 achiles kernel: usb 1-6: new high speed USB device using
ehci_hcd and address 4
Jun 29 10:03:30 achiles kernel: usb 1-6: configuration #1 chosen from 1 choice
Jun 29 10:03:30 achiles kernel: usb 1-6: New USB device found, idVendor=04a9,
idProduct=3117
Jun 29 10:03:30 achiles kernel: usb 1-6: New USB device strings: Mfr=1,
Product=2, SerialNumber=0
Jun 29 10:03:30 achiles kernel: usb 1-6: Product: Canon Digital Camera
Jun 29 10:03:30 achiles kernel: usb 1-6: Manufacturer: Canon Inc.
Jun 29 10:03:36 achiles kernel: gvfsd-gphoto2[3364]: segfault at c ip 00a8d7a0
sp bf8211fc error 4 in libpthread-2.8.so[a86000+15000]
Jun 29 10:03:44 achiles kernel: gvfsd-gphoto2[3380]: segfault at c ip 00a8d7a0
sp bfab72fc error 4 in libpthread-2.8.so[a86000+15000]


Version-Release number of selected component (if applicable): gphoto v2.4.0
release: 10.fc9
 

How reproducible: Always


Steps to Reproduce:
1. Connect camera via USB

  
Actual results:
DBUS timeout error - unable to mount (see attached image)

Expected results:
Should mount camera and launch the image viewer application to download images
to the computer.


Additional info:

Comment 1 Gerard Fernandes 2008-06-29 09:13:43 UTC
Created attachment 310531 [details]
error message

Comment 2 Jochen Wiedmann 2008-07-14 18:26:54 UTC
Possibly a duplicate of bug 445041


Comment 3 Gerard Fernandes 2008-10-23 09:49:04 UTC
Please close - doesn't occur anymore since the last few updates.

Comment 4 Jindrich Novy 2008-10-23 09:52:53 UTC
Ok, thanks for noticing.


Note You need to log in before you can comment on or make changes to this bug.