Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453288 - Rhythmbox is too picky about non [free] media...
Summary: Rhythmbox is too picky about non [free] media...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-28 22:57 UTC by Mario Torre
Modified: 2009-03-05 00:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-05 00:47:09 UTC


Attachments (Terms of Use)

Description Mario Torre 2008-06-28 22:57:37 UTC
Description of problem:
I know this using non free media is evil, but life is bad sometimes...

The problem is that Rhythmbox, every time that updates the library (so, it could
be even once per startup) start to complain for each file he can't find an
handler. This usually means all mp3 and aac files, for example, but even files
he can't understand and that for a reason are in the directories that it tries
to track, like tar.gz etc.. It would be just a little annoying if it was for
another big problem: he shows you a dialog box for *each* file!

So, if you have hundreds of unrecognized files, well... you guess what happens!

An ideal solution would be to make Rhythmbox smarter and not complain about
tar.gz at all, but I would be happy if it complain only once for all the files
that result to be "unknown" or "non free", instead of multiple times.

Version-Release number of selected component (if applicable):

[neugens@nirvana ~]$ rpm -q rhythmbox
rhythmbox-0.11.5-13.fc9.i386

How reproducible:
Always, just add non audio stuff (or non free format media) to your Rhythmbox
controlled directory.

Steps to Reproduce:
1. Run Rhythmbox
2. Close the popup dialog warning you the file is non free bla bla...
3. Repeat 2 for each unknow/not handled file...
  
Actual results:
Rhythmbox display the scaring dialog, once for file, and only after you close it
it show another one for the next file...

Expected results:
Show only one dialog, containing a list of all audio file [only] it could not
handle, maybe marking the file so that the next time he does not complain anymore.

Additional info:

Amarok is smarter but looks like an alien in my nice Gnome desktop...

Comment 1 Bastien Nocera 2009-03-05 00:47:09 UTC
This should be fixed in recent versions of Rhythmbox in F10. Please reopen if not.


Note You need to log in before you can comment on or make changes to this bug.