Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453281 - kernel fails to build if the BusLogic module is enabled
Summary: kernel fails to build if the BusLogic module is enabled
Keywords:
Status: CLOSED DUPLICATE of bug 445095
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-28 20:47 UTC by Akemi Yagi
Modified: 2008-07-24 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 12:28:28 UTC


Attachments (Terms of Use)

Description Akemi Yagi 2008-06-28 20:47:16 UTC
Description of problem: In the kernel shipped with CentOS 5.2, if BusLogic is
enabled ( CONFIG_SCSI_BUSLOGIC=m ),it generates these errors during kernel
compilation:

In file included from drivers/scsi/BusLogic.c:56:
drivers/scsi/BusLogic.h:241: error: redeclaration of enumerator ‘false’
include/linux/stddef.h:16: error: previous definition of ‘false’ was here
drivers/scsi/BusLogic.h:243: error: redeclaration of enumerator ‘true’
include/linux/stddef.h:18: error: previous definition of ‘true’ was here

This is because drivers/scsi/BusLogic.h contains:

typedef enum {
        false,
        true
} PACKED boolean;

and include/linux/stddef.h in the -92 kernel (but not in -53 or earlier) has:

enum {
        false = 0,
        true = 1
};

As a result, building the -92 kernel fails. 

Version-Release number of selected component (if applicable): kernel-2.6.18-92


How reproducible: Always


Steps to Reproduce:
1. Enable BusLogic in kernel config ( CONFIG_SCSI_BUSLOGIC=m )
2. Build the kernel
3.
  
Actual results: Compilation fails


Expected results:Compilation completes


Additional info: also filed with bugs.centos.org

Comment 1 Prarit Bhargava 2008-06-30 12:28:28 UTC

*** This bug has been marked as a duplicate of 445095 ***


Note You need to log in before you can comment on or make changes to this bug.